summaryrefslogtreecommitdiff
path: root/gnu/packages/busybox.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 17:17:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 22:00:23 +0200
commitf7705d4cb891b262a8b5247ff251dfc409cdeb6a (patch)
tree68f54af5f92f1ae990a5cd229c2772de3f5810c2 /gnu/packages/busybox.scm
parent5b34f56c1d645455137a16d94177a67358060fe4 (diff)
downloadguix-patches-f7705d4cb891b262a8b5247ff251dfc409cdeb6a.tar
guix-patches-f7705d4cb891b262a8b5247ff251dfc409cdeb6a.tar.gz
gnu: busybox: Return #t from all phases.
* gnu/packages/busybox.scm (busybox)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/busybox.scm')
-rw-r--r--gnu/packages/busybox.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index 6ef7200f9d..4cdea3a294 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -44,7 +45,7 @@
'(#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda _ (zero? (system* "make" "defconfig"))))
+ (lambda _ (invoke "make" "defconfig")))
(replace 'check
(lambda _
(substitute* '("testsuite/du/du-s-works"
@@ -71,18 +72,17 @@
(delete-file "testsuite/which/which-uses-default-path")
(rmdir "testsuite/which")
- (zero? (system* "make"
- ;; "V=1"
- "SKIP_KNOWN_BUGS=1"
- "SKIP_INTERNET_TESTS=1"
- "check"))))
+ (invoke "make"
+ ;; "V=1"
+ "SKIP_KNOWN_BUGS=1"
+ "SKIP_INTERNET_TESTS=1"
+ "check")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (zero?
- (system* "make"
- (string-append "CONFIG_PREFIX=" out)
- "install"))))))))
+ (invoke "make"
+ (string-append "CONFIG_PREFIX=" out)
+ "install")))))))
(native-inputs `(("perl" ,perl) ; needed to generate the man pages (pod2man)
;; The following are needed by the tests.
("inetutils" ,inetutils)