summaryrefslogtreecommitdiff
path: root/gnu/packages/busybox.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-12-23 04:12:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-12-25 01:47:22 +0200
commit7604106f2c6d00d6c68d2c2f1af062967fa89a97 (patch)
treeb1b2ad06dd415c466002f9803c695d66a0bff1ee /gnu/packages/busybox.scm
parentdb8255701314748c3a1199401b04a65e10866784 (diff)
downloadguix-patches-7604106f2c6d00d6c68d2c2f1af062967fa89a97.tar
guix-patches-7604106f2c6d00d6c68d2c2f1af062967fa89a97.tar.gz
gnu: busybox: Update to 1.26.0.
* gnu/packages/busybox.scm (busybox): Update to 1.26.0. [arguments]: Enable previously broken grep test.
Diffstat (limited to 'gnu/packages/busybox.scm')
-rw-r--r--gnu/packages/busybox.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index ecbdd6f939..988154eed4 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -30,7 +30,7 @@
(define-public busybox
(package
(name "busybox")
- (version "1.25.0")
+ (version "1.26.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -38,7 +38,7 @@
version ".tar.bz2"))
(sha256
(base32
- "1z52mh6prhd6v47qryz4rvng5r1z0am6masrnigq06zfhmlf03ss"))))
+ "0k0g3hk58m99c2sfq97ngnixb2rv2wzyhv3z00lxaw78bqvjglis"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -65,14 +65,6 @@
(substitute* "testsuite/pidof.tests"
(("-s init") "-s $(cat /proc/1/comm)"))
- (substitute* "testsuite/grep.tests"
- ;; The subject of this test is buggy. It is known by upstream (fixed in git)
- ;; So mark it with SKIP_KNOWN_BUGS like the others.
- ;; Presumably it wasn't known at the time of release ...
- ;; (It is strange that they release software which they know to have bugs)
- (("testing \"grep -w \\^str doesn't match str not at the beginning\"")
- "test x\"$SKIP_KNOWN_BUGS\" = x\"\" && testing \"grep -w ^str doesn't match str not at the beginning\""))
-
;; This test cannot possibly pass.
;; It is trying to test that "which ls" returns "/bin/ls" when PATH is not set.
;; However, this relies on /bin/ls existing. Which it does not in guix.