summaryrefslogtreecommitdiff
path: root/gnu/packages/busybox.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-06-14 13:03:05 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-06-14 13:03:05 +0200
commit4fdf3a2e6ef0d635e79aaf912c6997d2cd978835 (patch)
tree614111df6df59e1829fb16193f6bc734cd6a787d /gnu/packages/busybox.scm
parentc37dc30e61c56de1815750e52186c6de5be38ee9 (diff)
downloadguix-patches-4fdf3a2e6ef0d635e79aaf912c6997d2cd978835.tar
guix-patches-4fdf3a2e6ef0d635e79aaf912c6997d2cd978835.tar.gz
gnu: busybox: Update to 1.31.1.
* gnu/packages/patches/busybox-1.31.1-fix-build-with-glibc-2.31.patch: New file * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/busybox.scm (busybox): Update to 1.31.1. [source]: Use patch. [arguments]<#:phases>[check]: Fix test.
Diffstat (limited to 'gnu/packages/busybox.scm')
-rw-r--r--gnu/packages/busybox.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index 0d692c6586..305a61f40b 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -32,7 +32,7 @@
(define-public busybox
(package
(name "busybox")
- (version "1.29.3")
+ (version "1.31.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -40,7 +40,10 @@
version ".tar.bz2"))
(sha256
(base32
- "1dzg45vgy2w1xcd3p6h8d76ykhabbvk1h0lf8yb24ikrwlv8cr4p"))))
+ "1659aabzp8w4hayr4z8kcpbk2z1q2wqhw7i1yb0l72b45ykl1yfh"))
+ (patches
+ (search-patches
+ "busybox-1.31.1-fix-build-with-glibc-2.31.patch"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -79,6 +82,9 @@
(substitute* "testsuite/date/date-works-1"
(("/bin/date") (which "date")))
+ (substitute* "testsuite/start-stop-daemon.tests"
+ (("/bin/false") (which "false")))
+
;; The pidof tests assume that pid 1 is called "init" but that is not
;; true in guix build environment
(substitute* "testsuite/pidof.tests"