summaryrefslogtreecommitdiff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-10 05:00:03 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-10 05:01:38 +0100
commitca15eaeb069716892b9e060e7920460147f052bb (patch)
tree90bdc2f84d3e8bbe6dcc4c52e2f647bf77373ea6 /gnu/packages/build-tools.scm
parentf736dedc4f5d3a2702dea59f692ff3ac9bb3a978 (diff)
downloadguix-patches-ca15eaeb069716892b9e060e7920460147f052bb.tar
guix-patches-ca15eaeb069716892b9e060e7920460147f052bb.tar.gz
gnu: osc: Update to 0.172.0 [fixes CVE-2019-3681].
* gnu/packages/build-tools.scm (osc): Update to 0.172.0. [native-inputs]: Add python-chardet. Required by tests.
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 1b4a2effd5..ae3debd87f 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -462,7 +462,7 @@ a build worked by accident.")
(define-public osc
(package
(name "osc")
- (version "0.165.2")
+ (version "0.172.0")
(source
(origin
(method git-fetch)
@@ -471,7 +471,7 @@ a build worked by accident.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0yjwvbvv9fgkpiyvrag89zxchyn3nbgp9jz0wn5p0z9450zwfyz6"))))
+ (base32 "1sqdnkka3c6b6hwnrmlwrgy7w62cp8raq8mph9pgd2lydzzbvwlp"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -485,6 +485,8 @@ a build worked by accident.")
(string-append bin "osc-wrapper.py")
(string-append bin "osc"))
#t))))))
+ (native-inputs
+ `(("python-chardet" ,python-chardet)))
(inputs
`(("python-m2crypto" ,python-m2crypto)
("python-pycurl" ,python-pycurl)