summaryrefslogtreecommitdiff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-01 00:53:28 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-01 03:54:55 +0200
commit7c475372d2bd6dc4078dfab6703b4ca12a46dbd8 (patch)
treec6daa68664790c275b6eaa947416432b69dfc743 /gnu/packages/build-tools.scm
parentce2603bd1d4c5d84c4148f2fcd0abd1242d61faf (diff)
downloadguix-patches-7c475372d2bd6dc4078dfab6703b4ca12a46dbd8.tar
guix-patches-7c475372d2bd6dc4078dfab6703b4ca12a46dbd8.tar.gz
gnu: premake@5: Update to 5.0.0-alpha15.
* gnu/packages/build-tools.scm (premake5): Update to 5.0.0-alpha15. [arguments]: Modify ‘enter-source’ phase.
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index a0f3ae7f71..bb00cf431e 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -259,7 +259,7 @@ other lower-level build files.")
(define-public premake5
(package
(inherit premake4)
- (version "5.0.0-alpha14")
+ (version "5.0.0-alpha15")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/premake/premake-core/"
@@ -267,11 +267,13 @@ other lower-level build files.")
"/premake-" version "-src.zip"))
(sha256
(base32
- "0236s7bjvxf7x1l5faywmfzjywflpx42ngyhkn0mqqjnh54a97vw"))))
+ "0lyxfyqxyhjqsb3kmx1fyrxinb26i68hb7w7rg8lajczrgkmc3w8"))))
(arguments
(substitute-keyword-arguments (package-arguments premake4)
((#:phases phases)
`(modify-phases ,phases
+ (replace 'enter-source
+ (lambda _ (chdir "build/gmake2.unix") #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(install-file "../../bin/release/premake5"