summaryrefslogtreecommitdiff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
commit57df83e07d4b5e78d9a54c1a88d05b4a9ed65714 (patch)
tree76684e63965e9ad6e37d9d45bc3159e6c9782cd0 /gnu/packages/build-tools.scm
parent43d9ed7792808638eabb43aa6133f1d6186c520b (diff)
parent136b7d81f0eb713783e9ea7cf7f260a2b6252dfd (diff)
downloadguix-patches-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar
guix-patches-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm31
1 files changed, 16 insertions, 15 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 34f0037e6a..459d691c45 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
+;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +34,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages package-management)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
@@ -240,21 +242,22 @@ other lower-level build files.")
(define-public osc
(package
(name "osc")
- (version "0.162.1")
+ (version "0.165.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/openSUSE/" name
- "/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openSUSE/osc")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0b4kpm96ns4smqyfjysbk2p78d36x44xprpna8zz85q1y5xn57aj"))))
+ (base32
+ "0l6iw8a040l60ixxdms9rxajm38vqfdwgij2bm7ahgv1akza64jk"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2 ; Module is python2 only.
- #:phases
+ `(#:phases
(modify-phases %standard-phases
- (add-after 'install 'fix-filename-and-remove-unused
+ (add-after 'install 'fix-filename
(lambda* (#:key outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
;; Main osc tool is renamed in spec file, not setup.py, let's
@@ -262,13 +265,11 @@ other lower-level build files.")
(rename-file
(string-append bin "osc-wrapper.py")
(string-append bin "osc"))
- ;; Remove unused and broken script.
- (delete-file (string-append bin "osc_hotshot.py"))
- #t))))))
+ #t))))))
(inputs
- `(("python2-m2crypto" ,python2-m2crypto)
- ("python2-pycurl" ,python2-pycurl)
- ("python2-urlgrabber" ,python2-urlgrabber)))
+ `(("python-m2crypto" ,python-m2crypto)
+ ("python-pycurl" ,python-pycurl)
+ ("rpm" ,rpm))) ; for python-rpm
(home-page "https://github.com/openSUSE/osc")
(synopsis "Open Build Service command line tool")
(description "@command{osc} is a command line interface to the Open Build