summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-08-02 22:17:11 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-08-04 14:32:36 +0200
commitfe6775f52b7f28a5bf74633ea4737c32a64b7e05 (patch)
tree58ced4e6cff4d87e95c8e26c2ffe03fb0695cf0f /gnu/packages/bootstrap.scm
parent5324e66f9df62d776dbf0237ce4a7494eaad4988 (diff)
downloadguix-patches-fe6775f52b7f28a5bf74633ea4737c32a64b7e05.tar
guix-patches-fe6775f52b7f28a5bf74633ea4737c32a64b7e05.tar.gz
gnu: bootstrap-gcc: Don't use CPATH search paths.
This updates the bootstrap-gcc to use the same search path strategy as the main compilers, making the bootstrap environment more similar across architectures, and fixing the bootstrap path on non-x86 architectures again. This is a follow up to commit 7cde865f12dd67e55946a52a21103e71f447eced. * gnu/packages/bootstrap.scm (%bootstrap-gcc)[native-search-paths]: Use C_INCLUDE_PATH and CPLUS_INCLUDE_PATH instead of CPATH.
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index c39e60ec8b..fee2ae1199 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2019 Carl Dong <contact@carldong.me>
;;; Copyright © 2019 Léo Le Bouter <lle-bout@zaclys.net>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -740,9 +741,12 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
"1m5miqkyng45l745n0sfafdpjkqv9225xf44jqkygwsipj2cv9ks")))))))))
(native-search-paths
(list (search-path-specification
- (variable "CPATH")
+ (variable "C_INCLUDE_PATH")
(files '("include")))
(search-path-specification
+ (variable "CPLUS_INCLUDE_PATH")
+ (files '("include/c++" "include")))
+ (search-path-specification
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))
(synopsis "Bootstrap binaries of the GNU Compiler Collection")