summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-15 23:42:58 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-15 23:42:58 +0200
commitdfb52abbd60876de250f04fc5c64b3c85082cba6 (patch)
tree1ba75d6d5d217253dcb161a8dbf1387199ae577b /gnu/packages/bootstrap.scm
parent59fbeb8cae02032a2f8b7966ab52545817f3ed88 (diff)
downloadguix-patches-dfb52abbd60876de250f04fc5c64b3c85082cba6.tar
guix-patches-dfb52abbd60876de250f04fc5c64b3c85082cba6.tar.gz
Remove weirdnesses caused by 'letrec*' behavior of record field initializers.
* gnu/packages/bootstrap.scm (package-from-tarball): Remove '*' from parameter names. Adjust accordingly. * gnu/packages/linux-initrd.scm (expression->initrd): Use 'name' directly, removing the 'name*' alias. * gnu/packages/linux.scm (linux-libre-headers, linux-libre): Rename 'version*' to 'version'.
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index a1d4c7fc67..11f54ad051 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -70,14 +70,13 @@
(boot url-fetch))
(else orig-method))))))
-(define (package-from-tarball name* source* program-to-test description*)
- "Return a package that correspond to the extraction of SOURCE*.
-PROGRAM-TO-TEST is a program to run after extraction of SOURCE*, to
+(define (package-from-tarball name source program-to-test description)
+ "Return a package that correspond to the extraction of SOURCE.
+PROGRAM-TO-TEST is a program to run after extraction of SOURCE, to
check whether everything is alright."
(package
- (name name*)
+ (name name)
(version "0")
- (source #f)
(build-system trivial-build-system)
(arguments
`(#:guile ,%bootstrap-guile
@@ -101,8 +100,9 @@ check whether everything is alright."
(inputs
`(("tar" ,(search-bootstrap-binary "tar" (%current-system)))
("xz" ,(search-bootstrap-binary "xz" (%current-system)))
- ("tarball" ,(bootstrap-origin (source* (%current-system))))))
- (synopsis description*)
+ ("tarball" ,(bootstrap-origin (source (%current-system))))))
+ (source #f)
+ (synopsis description)
(description #f)
(home-page #f)
(license #f)))