summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-20 17:52:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-20 18:23:14 +0100
commitd64bcccf43b0af2c7a113f498096fa021602b779 (patch)
treedcfc9b71a002fb0cd5c8938b97e2f5cbf7bee74e /gnu/packages/bootloaders.scm
parent5fa6b52a548a806c36a450448972ae4007bbac17 (diff)
downloadguix-patches-d64bcccf43b0af2c7a113f498096fa021602b779.tar
guix-patches-d64bcccf43b0af2c7a113f498096fa021602b779.tar.gz
gnu: grub: Run tests against Qemu 2.10.
* gnu/packages/bootloaders.scm (qemu-minimal-2.10): New variable. (grub)[native-inputs]: Replace QEMU-MINIMAL with QEMU-MINIMAL-2.10.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 59eb22f242..70b392f3c1 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -71,6 +71,21 @@
(base32
"0p2vhnc18cnbmb39vq4m7hzv4mhnm2l0a2s7gx3ar277fwng3hys"))))
+;; The GRUB test suite fails with later versions of Qemu, so we
+;; keep it at 2.10 for now. See
+;; <https://lists.gnu.org/archive/html/bug-grub/2018-02/msg00004.html>.
+(define qemu-minimal-2.10
+ (package
+ (inherit qemu-minimal)
+ (version "2.10.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.qemu.org/qemu-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "17w21spvaxaidi2am5lpsln8yjpyp2zi3s3gc6nsxj5arlgamzgw"))))))
+
(define-public grub
(package
(name "grub")
@@ -144,7 +159,7 @@
;; Dependencies for the test suite. The "real" QEMU is needed here,
;; because several targets are used.
("parted" ,parted)
- ("qemu" ,qemu-minimal)
+ ("qemu" ,qemu-minimal-2.10)
("xorriso" ,xorriso)))
(home-page "https://www.gnu.org/software/grub/")
(synopsis "GRand Unified Boot loader")