summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authornee <nee@cock.li>2019-01-16 14:01:17 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-16 14:07:38 +0100
commitab100b905f4073b24d69af3de6de61c4c55ce27d (patch)
treecccb25e02f5ec8d620050920f881291dd1ac6eab /gnu/packages/bootloaders.scm
parent61b7f97177da423d87e142e92af008f2bf1dbd6b (diff)
downloadguix-patches-ab100b905f4073b24d69af3de6de61c4c55ce27d.tar
guix-patches-ab100b905f4073b24d69af3de6de61c4c55ce27d.tar.gz
gnu: grub: Add dependency on console-setup.
* gnu/packages/bootloaders.scm (grub)[arguments]: In 'patch-stuff' phase, patch 'grub-kbdcomp.in'. [inputs]: Add CONSOLE-SETUP. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 69b4a904be..1cf7720a73 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
@@ -8,6 +8,7 @@
;;; Copyright © 2016, 2017 David Craven <david@craven.ch>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 nee <nee@cock.li>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,6 +56,7 @@
#:use-module (gnu packages swig)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages virtualization)
+ #:use-module (gnu packages xorg)
#:use-module (gnu packages web)
#:use-module (guix build-system gnu)
#:use-module (guix download)
@@ -110,6 +112,12 @@
;; Make the font visible.
(copy-file (assoc-ref inputs "unifont") "unifont.bdf.gz")
(system* "gunzip" "unifont.bdf.gz")
+
+ ;; Give the absolute file name of 'ckbcomp'.
+ (substitute* "util/grub-kbdcomp.in"
+ (("^ckbcomp ")
+ (string-append (assoc-ref inputs "console-setup")
+ "/bin/ckbcomp ")))
#t))
(add-before 'check 'disable-flaky-test
(lambda _
@@ -134,6 +142,10 @@
;; to determine whether the root file system is RAID.
("mdadm" ,mdadm)
+ ;; Console-setup's ckbcomp is invoked by grub-kbdcomp. It is required
+ ;; for generating alternative keyboard layouts.
+ ("console-setup" ,console-setup)
+
("freetype" ,freetype)
;; ("libusb" ,libusb)
;; ("fuse" ,fuse)