summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-09-26 06:24:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-09-26 06:28:23 +0200
commit91af1031e53e85e4200046ae47c38067c3dd7a85 (patch)
treec87c69d45c8ee43326f0a0c08b8b7f00c4fee0fc /gnu/packages/bootloaders.scm
parentf70e567eea1e6adac209053fdc6dddbeec06b148 (diff)
downloadguix-patches-91af1031e53e85e4200046ae47c38067c3dd7a85.tar
guix-patches-91af1031e53e85e4200046ae47c38067c3dd7a85.tar.gz
gnu: dtc: Update to 1.5.1.
* gnu/packages/bootloaders.scm (dtc): Update to 1.5.1. [arguments]: Add -Wl,-rpath to LDFLAGS #:make-flags.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index b235e1bc78..520728b52c 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -357,7 +357,7 @@ menu to select one of the installed operating systems.")
(define-public dtc
(package
(name "dtc")
- (version "1.5.0")
+ (version "1.5.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -365,7 +365,7 @@ menu to select one of the installed operating systems.")
"dtc-" version ".tar.xz"))
(sha256
(base32
- "0wh10p42hf5403ipvs0dsxddb6kzfyk2sq4fgid9zqzpr51y8wn6"))))
+ "07q3mdsvl4smbiakriq3hnsyyd0q344lsm306q0kgz4hjq1p82v6"))))
(build-system gnu-build-system)
(native-inputs
`(("bison" ,bison)
@@ -379,6 +379,11 @@ menu to select one of the installed operating systems.")
(arguments
`(#:make-flags
(list "CC=gcc"
+
+ ;; /bin/fdt{get,overlay,put} need help finding libfdt.so.1.
+ (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib")
+
(string-append "PREFIX=" (assoc-ref %outputs "out"))
(string-append "SETUP_PREFIX=" (assoc-ref %outputs "out"))
"INSTALL=install")