summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2018-11-20 16:32:16 -0800
committerDanny Milosavljevic <dannym@scratchpost.org>2018-11-22 21:59:05 +0100
commit74e35e8c94193a03cb1db61934340540ce0884a3 (patch)
tree4e94ca14c1977c2661d6dd857fbd3d78990c783a /gnu/packages/bootloaders.scm
parenteff8e0b4d9d4b818150f64e151227e03fdcb5aab (diff)
downloadguix-patches-74e35e8c94193a03cb1db61934340540ce0884a3.tar
guix-patches-74e35e8c94193a03cb1db61934340540ce0884a3.tar.gz
gnu: Add u-boot-pinebook.
* gnu/packages/patches/u-boot-pinebook-a64-update-dts.patch: New file. * gnu/packages/patches/u-boot-pinebook-syscon-node.patch: New file. * gnu/packages/patches/u-boot-pinebook-mmc-calibration.patch: New file. * gnu/packages/patches/u-boot-pinebook-video-bridge.patch: New file. * gnu/packages/patches/u-boot-pinebook-r_i2c-controller.patch: New file. * gnu/packages/patches/u-boot-pinebook-dts.patch: New file. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/bootloaders.scm (u-boot-pinebook): New exported variable. * gnu/bootloader/u-boot.scm (u-boot-pinebook-bootloader): New exported variable. * gnu/system/install.scm (pinebook-installation-os): New exported variable.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 328e834bc2..0c11639150 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -579,6 +579,22 @@ board-independent tools.")))
(define-public u-boot-pine64-plus
(make-u-boot-sunxi64-package "pine64_plus" "aarch64-linux-gnu"))
+(define-public u-boot-pinebook
+ (let ((base (make-u-boot-sunxi64-package "pinebook" "aarch64-linux-gnu")))
+ (package
+ (inherit base)
+ (source (origin
+ (inherit (package-source u-boot))
+ (patches (search-patches
+ ;; Add patches to enable Pinebook support from sunxi
+ ;; maintainer tree: git://git.denx.de/u-boot-sunxi.git
+ "u-boot-pinebook-a64-update-dts.patch"
+ "u-boot-pinebook-syscon-node.patch"
+ "u-boot-pinebook-mmc-calibration.patch"
+ "u-boot-pinebook-video-bridge.patch"
+ "u-boot-pinebook-r_i2c-controller.patch"
+ "u-boot-pinebook-dts.patch")))))))
+
(define-public u-boot-bananapi-m2-ultra
(make-u-boot-package "Bananapi_M2_Ultra" "arm-linux-gnueabihf"))