summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2019-04-28 20:55:39 -0700
committerDanny Milosavljevic <dannym@scratchpost.org>2019-04-30 19:49:16 +0200
commit6f5be83cd7158e678602d62c27f26363df3e1649 (patch)
tree3059e049d94654671ce4ac0cc1c20b7f13dcf131 /gnu/packages/bootloaders.scm
parent9b241d4ce200e09d34f15014446eb6bc5ed96f3e (diff)
downloadguix-patches-6f5be83cd7158e678602d62c27f26363df3e1649.tar
guix-patches-6f5be83cd7158e678602d62c27f26363df3e1649.tar.gz
gnu: u-boot-tools: Only run full test suite on x86_64.
* gnu/packages/bootloaders (u-boot-tools)[arguments]<#:phases>[check]: Modify phase. [check-x86]: New phase. [patch]: New phase.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm23
1 files changed, 17 insertions, 6 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index e1d91b136c..6e6e69ff3b 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -445,6 +445,10 @@ also initializes the boards (RAM etc).")
(("def test_ctrl_c")
"@pytest.mark.skip(reason='Guix has problems with SIGINT')
def test_ctrl_c"))
+ ;; Test against the tools being installed rather than tools built
+ ;; for "sandbox" target.
+ (substitute* "test/image/test-imagetools.sh"
+ (("BASEDIR=sandbox") "BASEDIR=."))
(for-each (lambda (file)
(substitute* file
;; Disable signatures, due to GPL/Openssl
@@ -487,12 +491,19 @@ def test_ctrl_c"))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key make-flags test-target #:allow-other-keys)
- (apply invoke "make" "mrproper" make-flags)
- (setenv "SDL_VIDEODRIVER" "dummy")
- (setenv "PAGER" "cat")
- (apply invoke "make" test-target make-flags)
- (symlink "build-sandbox_spl" "sandbox")
- (invoke "test/image/test-imagetools.sh"))))))
+ (invoke "test/image/test-imagetools.sh")))
+ ;; Only run full test suite on x86_64 systems, as many tests
+ ;; assume x86_64.
+ ,@(if (string-match "^x86_64-linux"
+ (or (%current-target-system)
+ (%current-system)))
+ '((add-after 'check 'check-x86
+ (lambda* (#:key make-flags test-target #:allow-other-keys)
+ (apply invoke "make" "mrproper" make-flags)
+ (setenv "SDL_VIDEODRIVER" "dummy")
+ (setenv "PAGER" "cat")
+ (apply invoke "make" test-target make-flags))))
+ '()))))
(description "U-Boot is a bootloader used mostly for ARM boards. It
also initializes the boards (RAM etc). This package provides its
board-independent tools.")))