summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2022-04-05 12:01:03 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-04-05 12:05:22 -0700
commit4a0d0459903e0f2d89176120de1377e798b7d55d (patch)
tree40a28ec71b1f8513e6fd2b0a0f374d8136ac2674 /gnu/packages/bootloaders.scm
parent20302e0b161a9a44e8630c65658bc11057834da5 (diff)
downloadguix-patches-4a0d0459903e0f2d89176120de1377e798b7d55d.tar
guix-patches-4a0d0459903e0f2d89176120de1377e798b7d55d.tar.gz
gnu: u-boot: Update to 2022.04.
* gnu/packages/bootloaders.scm (u-boot): Update to 2022.01. [native-inputs]: Add gnutls, tinfo, libuuid. (u-boot-qemu-riscv64-smode): Drop custom patches. * gnu/packages/patches/u-boot-allow-disabling-openssl.patch: Refresh patch. * gnu/packages/patches/u-boot-riscv64-fix-extlinux.patch: Remove patch, applied upstream. * gnu/local.mk (dist_patch_DATA): Update with removed patches. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 7987641031..40ad72c04b 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -517,7 +517,7 @@ tree binary files. These are board description files used by Linux and BSD.")
(define u-boot
(package
(name "u-boot")
- (version "2021.10")
+ (version "2022.04")
(source (origin
(patches
(list %u-boot-rockchip-inno-usb-patch
@@ -530,19 +530,22 @@ tree binary files. These are board description files used by Linux and BSD.")
"u-boot-" version ".tar.bz2"))
(sha256
(base32
- "1m0bvwv8r62s4wk4w3cmvs888dhv9gnfa98dczr4drk2jbhj7ryd"))))
+ "1l5w13dznj0z1ibqv2d6ljx2ma1gnf5x5ay3dqkqwxr6750nbq38"))))
(native-inputs
`(("bc" ,bc)
("bison" ,bison)
("dtc" ,dtc)
+ ("gnutls" ,gnutls)
("flex" ,flex)
("lz4" ,lz4)
+ ("tinfo" ,ncurses/tinfo)
("perl" ,perl)
("python" ,python)
("python-coverage" ,python-coverage)
("python-pycryptodomex" ,python-pycryptodomex)
("python-pytest" ,python-pytest)
- ("swig" ,swig)))
+ ("swig" ,swig)
+ ("libuuid" ,util-linux "lib")))
(build-system gnu-build-system)
(home-page "https://www.denx.de/wiki/U-Boot/")
(synopsis "ARM bootloader")
@@ -911,14 +914,7 @@ to Novena upstream, does not load u-boot.img from the first partition.")
(make-u-boot-package "qemu-riscv64" "riscv64-linux-gnu"))
(define-public u-boot-qemu-riscv64-smode
- (let ((base (make-u-boot-package "qemu-riscv64_smode" "riscv64-linux-gnu")))
- (package
- (inherit base)
- (source (origin
- (inherit (package-source u-boot))
- (patches
- (search-patches "u-boot-riscv64-fix-extlinux.patch"
- %u-boot-allow-disabling-openssl-patch)))))))
+ (make-u-boot-package "qemu-riscv64_smode" "riscv64-linux-gnu"))
(define-public u-boot-sifive-unleashed
(make-u-boot-package "sifive_unleashed" "riscv64-linux-gnu"))