summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-04-26 08:14:50 +0200
committerRutger Helling <rhelling@mykolab.com>2018-04-26 12:45:57 +0200
commit27b52c1f6aa036ec99691a5c76ecf697e09cd62f (patch)
treece32dd873565a42b38f6ae51791cbbb5ab97d7bc /gnu/packages/bootloaders.scm
parent87bcd9bf655035bda31b2921a88ed14d9b6fa2e8 (diff)
downloadguix-patches-27b52c1f6aa036ec99691a5c76ecf697e09cd62f.tar
guix-patches-27b52c1f6aa036ec99691a5c76ecf697e09cd62f.tar.gz
gnu: qemu: Build with Python 3 and SDL2 support.
* gnu/packages/bootloaders.scm (qemu-minimal-2.10): Remove variable. * gnu/packages/virtualization.scm (qemu)[inputs]: Use sdl2 instead of sdl. [native-inputs]: Use python-wrapper instead of python@2. * gnu/packages/virtualization.scm (qemu-minimal)[inputs]: Remove sdl2 instead of sdl from inherited packages. * gnu/packages/virtualization.scm (qemu-minimal-2.10): Add variable. [native-inputs]: Remove python-wrapper from inherited packages and use python@2 instead. * gnu/packages/debug.scm (american-fuzzy-lop): Inherit from moved hidden-package qemu-minimal-2.10.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm16
1 files changed, 0 insertions, 16 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 281bb98fa9..4350ff3a50 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -72,22 +72,6 @@
(base32
"0p2vhnc18cnbmb39vq4m7hzv4mhnm2l0a2s7gx3ar277fwng3hys"))))
-;; The GRUB test suite fails with later versions of Qemu, so we
-;; keep it at 2.10 for now. See
-;; <https://lists.gnu.org/archive/html/bug-grub/2018-02/msg00004.html>.
-;; TODO: When grub no longer needs this version, move to gnu/packages/debug.scm.
-(define qemu-minimal-2.10
- (package
- (inherit qemu-minimal)
- (version "2.10.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://download.qemu.org/qemu-"
- version ".tar.xz"))
- (sha256
- (base32
- "17w21spvaxaidi2am5lpsln8yjpyp2zi3s3gc6nsxj5arlgamzgw"))))))
-
(define-public grub
(package
(name "grub")