summaryrefslogtreecommitdiff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2020-02-02 02:07:17 +0000
committerVagrant Cascadian <vagrant@debian.org>2020-02-01 18:14:13 -0800
commit1f9fae008d52a9901d016d418d3931f6e9ccbd00 (patch)
treeb4eea5c69e45b8580abbafea92d8eecb11dc67a1 /gnu/packages/bootloaders.scm
parentb3d25e218aeacead1194a0efcb8b83784d220835 (diff)
downloadguix-patches-1f9fae008d52a9901d016d418d3931f6e9ccbd00.tar
guix-patches-1f9fae008d52a9901d016d418d3931f6e9ccbd00.tar.gz
gnu: u-boot-qemu-riscv64-smode: Patch to fix boot menu.
* gnu/packages/patches/u-boot-riscv64-fix-extlinux.patch: New patch. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/bootloaders (u-boot-qemu-riscv64-smode): Add patch.
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index be5e4eebb1..63a88dd7ec 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -755,7 +755,13 @@ to Novena upstream, does not load u-boot.img from the first partition.")
(make-u-boot-package "qemu-riscv64" "riscv64-linux-gnu"))
(define-public u-boot-qemu-riscv64-smode
- (make-u-boot-package "qemu-riscv64_smode" "riscv64-linux-gnu"))
+ (let ((base (make-u-boot-package "qemu-riscv64_smode" "riscv64-linux-gnu")))
+ (package
+ (inherit base)
+ (source (origin
+ (inherit (package-source u-boot))
+ (patches
+ (search-patches "u-boot-riscv64-fix-extlinux.patch")))))))
(define-public u-boot-sifive-fu540
(make-u-boot-package "sifive_fu540" "riscv64-linux-gnu"))