summaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-02 21:17:53 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-02 21:17:53 +0200
commite7a42c4abb2f6b81c4e42b7715dd4724370b713c (patch)
treee571de71d40dae7c6f1e79bfeebf0cd663d36865 /gnu/packages/boost.scm
parentfefd1a7bd45f949ca062ba984a58532093dab841 (diff)
downloadguix-patches-e7a42c4abb2f6b81c4e42b7715dd4724370b713c.tar
guix-patches-e7a42c4abb2f6b81c4e42b7715dd4724370b713c.tar.gz
gnu: boost: Remove GCC5 workaround.
* gnu/packages/patches/boost-fix-icu-build.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/boost.scm (boost)[source](patches): Remove. [arguments]: Do not pass "cxxflags".
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 73b4cff4c8..6b8eebcecb 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -56,8 +56,7 @@
version-with-underscores ".tar.bz2"))))
(sha256
(base32
- "0y47nc7w0arwgj4x1phadxbvl7wyfcgknbz5kv8lzpl98wsyh2j3"))
- (patches (search-patches "boost-fix-icu-build.patch"))))
+ "0y47nc7w0arwgj4x1phadxbvl7wyfcgknbz5kv8lzpl98wsyh2j3"))))
(build-system gnu-build-system)
(inputs `(("icu4c" ,icu4c)
("zlib" ,zlib)))
@@ -69,7 +68,6 @@
`(#:tests? #f
#:make-flags
(list "threading=multi" "link=shared"
- "cxxflags=-std=c++14"
;; Set the RUNPATH to $libdir so that the libs find each other.
(string-append "linkflags=-Wl,-rpath="