summaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-16 11:32:39 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 17:08:14 +0200
commitb08d989045450c72260e3781ef458555b9e2597c (patch)
tree059a69b93aa2cd6d5209b7e8bfe8bf4995ada8d9 /gnu/packages/boost.scm
parent52f4ba9617d39f52d5a1db3aadfe6475221e3d43 (diff)
downloadguix-patches-b08d989045450c72260e3781ef458555b9e2597c.tar
guix-patches-b08d989045450c72260e3781ef458555b9e2597c.tar.gz
gnu: boost: Update to 1.76.0.
* gnu/packages/patches/boost-fix-transitive-linking.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/boost.scm (boost): Update to 1.76.0. [source](patches): Remove.
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index c6cf452f09..e9da56e115 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -66,17 +66,15 @@
(define-public boost
(package
(name "boost")
- (version "1.75.0")
+ (version "1.76.0")
(source (origin
(method url-fetch)
(uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
version "/source/boost_"
(version-with-underscores version) ".tar.bz2"))
- ; Should be included in next Boost update
- (patches (search-patches "boost-fix-transitive-linking.patch"))
(sha256
(base32
- "1js9zpij58l60kx46s3lxdp5207igppjnhqigwhbpdvd04gb6gcm"))))
+ "0hcc661savk32hx65997p0ss1awj6ala4cmz4w7lbi42x6k7nfgh"))))
(build-system gnu-build-system)
(inputs `(("icu4c" ,icu4c)
("zlib" ,zlib)))