summaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-23 19:06:23 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-31 14:41:36 +0200
commit941ef1a1e54893ca917ebbaa4b8cc14b5ce9b75c (patch)
tree7315811ecfa8581a31c6f7edcf55ce14381e9809 /gnu/packages/boost.scm
parent14767d4466c7f7bcf32c68b2d10cc359c79d7160 (diff)
downloadguix-patches-941ef1a1e54893ca917ebbaa4b8cc14b5ce9b75c.tar
guix-patches-941ef1a1e54893ca917ebbaa4b8cc14b5ce9b75c.tar.gz
gnu: boost: Do not install CMake files.
Fixes <https://bugs.gnu.org/36721>. * gnu/packages/boost.scm (boost)[arguments]: Add "--no-cmake-config" to <#:configure-flags>.
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 6b8eebcecb..a2253a9efc 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -69,6 +69,11 @@
#:make-flags
(list "threading=multi" "link=shared"
+ ;; XXX: Disable installation of Boosts modular CMake config scripts
+ ;; which conflicts in 1.70.0 with the ones provided by CMake.
+ ;; See <https://bugs.gnu.org/36721>.
+ "--no-cmake-config"
+
;; Set the RUNPATH to $libdir so that the libs find each other.
(string-append "linkflags=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))