summaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-02-22 23:59:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-23 13:40:19 +0100
commit71154fe737b135cf9d53e9af8c410920e42523ac (patch)
tree9a9147d554dcbfc7bd7899677bed304b0d53f097 /gnu/packages/boost.scm
parent400457af5ff3824cd189176293e5b2723945ed00 (diff)
downloadguix-patches-71154fe737b135cf9d53e9af8c410920e42523ac.tar
guix-patches-71154fe737b135cf9d53e9af8c410920e42523ac.tar.gz
gnu: Add boost-signals2.
* gnu/packages/boost.scm (boost-signals2): New variable.
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 8f5ac33700..b83bd73a39 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
@@ -182,6 +182,34 @@ and events and other thread related facilities. Boost.Sync originated from
Boost.Thread.")
(license (license:x11-style "https://www.boost.org/LICENSE_1_0.txt")))))
+(define-public boost-signals2
+ (package
+ (name "boost-signals2")
+ (version (package-version boost))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/boostorg/signals2.git")
+ (commit (string-append "boost-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nayaqshhzr1n6jj43bpvvay36d5gn075h0b95psii5x8ingszdk"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((source (assoc-ref %build-inputs "source")))
+ (copy-recursively (string-append source "/include")
+ (string-append %output "/include"))))))
+ (home-page "https://github.com/boostorg/signals2")
+ (synopsis "Boost.Signals2 library")
+ (description "The Boost.Signals2 library is an implementation of a managed
+signals and slots system.")
+ (license (license:x11-style "https://www.boost.org/LICENSE_1_0.txt"))))
+
(define-public mdds
(package
(name "mdds")