summaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-08-01 23:30:52 +0200
committerLudovic Courtès <ludo@gnu.org>2016-08-01 23:30:52 +0200
commit455859a50f88f625d13fc2f304111f02369b366b (patch)
tree285d8aa9253f033fa8d64e6b5f9f8d856aae04d2 /gnu/packages/boost.scm
parent742effef5629667b274087adc70b06abab86b252 (diff)
downloadguix-patches-455859a50f88f625d13fc2f304111f02369b366b.tar
guix-patches-455859a50f88f625d13fc2f304111f02369b366b.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm80
1 files changed, 40 insertions, 40 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index bb123d38a4..fd8f4e80e3 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -51,50 +51,50 @@
("python" ,python-2)
("tcsh" ,tcsh)))
(arguments
- (let ((build-flags
- `("threading=multi" "link=shared"
+ `(#:tests? #f
+ #:make-flags
+ (list "threading=multi" "link=shared"
- ;; Set the RUNPATH to $libdir so that the libs find each other.
- (string-append "linkflags=-Wl,-rpath="
- (assoc-ref outputs "out") "/lib")
+ ;; Set the RUNPATH to $libdir so that the libs find each other.
+ (string-append "linkflags=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib")
- ;; Boost's 'context' library is not yet supported on mips64, so
- ;; we disable it. The 'coroutine' library depends on 'context',
- ;; so we disable that too.
- ,@(if (string-prefix? "mips64" (or (%current-target-system)
- (%current-system)))
- '("--without-context"
- "--without-coroutine" "--without-coroutine2")
- '()))))
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* '("libs/config/configure"
- "libs/spirit/classic/phoenix/test/runtest.sh"
- "tools/build/doc/bjam.qbk"
- "tools/build/src/engine/execunix.c"
- "tools/build/src/engine/Jambase"
- "tools/build/src/engine/jambase.c")
- (("/bin/sh") (which "sh")))
+ ;; Boost's 'context' library is not yet supported on mips64, so
+ ;; we disable it. The 'coroutine' library depends on 'context',
+ ;; so we disable that too.
+ ,@(if (string-prefix? "mips64" (or (%current-target-system)
+ (%current-system)))
+ '("--without-context"
+ "--without-coroutine" "--without-coroutine2")
+ '()))
+ #:phases
+ (modify-phases %standard-phases
+ (replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* '("libs/config/configure"
+ "libs/spirit/classic/phoenix/test/runtest.sh"
+ "tools/build/doc/bjam.qbk"
+ "tools/build/src/engine/execunix.c"
+ "tools/build/src/engine/Jambase"
+ "tools/build/src/engine/jambase.c")
+ (("/bin/sh") (which "sh")))
- (setenv "SHELL" (which "sh"))
- (setenv "CONFIG_SHELL" (which "sh"))
+ (setenv "SHELL" (which "sh"))
+ (setenv "CONFIG_SHELL" (which "sh"))
- (zero? (system* "./bootstrap.sh"
- (string-append "--prefix=" out)
- "--with-toolset=gcc")))))
- (replace
- 'build
- (lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* "./b2" ,@build-flags))))
- (replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* "./b2" "install" ,@build-flags))))))))
+ (zero? (system* "./bootstrap.sh"
+ (string-append "--prefix=" out)
+ "--with-toolset=gcc")))))
+ (replace
+ 'build
+ (lambda* (#:key outputs make-flags #:allow-other-keys)
+ (zero? (apply system* "./b2" make-flags))))
+ (replace
+ 'install
+ (lambda* (#:key outputs make-flags #:allow-other-keys)
+ (zero? (apply system* "./b2" "install" make-flags)))))))
(home-page "http://boost.org")
(synopsis "Peer-reviewed portable C++ source libraries")