summaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-17 23:08:07 -0400
committerMark H Weaver <mhw@netris.org>2018-03-18 00:48:55 -0400
commit196fb12cb8311ced90e51d9246deeea432ecce58 (patch)
treed1257f492b450f44333a771dd74c8377c3a2c934 /gnu/packages/boost.scm
parent81f6bf2d50ec18d2ca5fff198e9068402437b699 (diff)
downloadguix-patches-196fb12cb8311ced90e51d9246deeea432ecce58.tar
guix-patches-196fb12cb8311ced90e51d9246deeea432ecce58.tar.gz
gnu: boost: Simplify phases.
* gnu/packages/boost.scm (boost)[arguments]: Remove unneeded '#t's from 'configure', 'build', and 'install' phases.
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index ebfe2a82bf..f7e90b4a77 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -92,18 +92,15 @@
(invoke "./bootstrap.sh"
(string-append "--prefix=" out)
- "--with-toolset=gcc")
- #t)))
+ "--with-toolset=gcc"))))
(replace 'build
- (lambda* (#:key outputs make-flags #:allow-other-keys)
+ (lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "./b2"
(format #f "-j~a" (parallel-job-count))
- make-flags)
- #t))
+ make-flags)))
(replace 'install
- (lambda* (#:key outputs make-flags #:allow-other-keys)
- (apply invoke "./b2" "install" make-flags)
- #t)))))
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "./b2" "install" make-flags))))))
(home-page "http://www.boost.org")
(synopsis "Peer-reviewed portable C++ source libraries")