summaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-10-26 13:49:08 +0100
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-10-26 14:23:10 +0100
commit061ffcf2ad98f82816e1bde568d0bcd4fb73eae0 (patch)
treee4f701224bdb4c78dad3a6f93f231090f3930706 /gnu/packages/boost.scm
parentf602f3041e6c4df3ce1bbdd5390fc6815b3027e9 (diff)
downloadguix-patches-061ffcf2ad98f82816e1bde568d0bcd4fb73eae0.tar
guix-patches-061ffcf2ad98f82816e1bde568d0bcd4fb73eae0.tar.gz
gnu: boost: Move conditional configure fix for the Hurd inline.
* gnu/packages/boost.scm (boost)[arguments]: Inline configure substitution for the Hurd.
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 709b10fba0..fcadc03dd0 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -134,13 +134,9 @@
'())
;; Change an #ifdef __MACH__ that really targets macOS.
- ;; TODO: Inline this on the next rebuild cycle.
- ,@(if (hurd-target?)
- '((substitute* "boost/test/utils/timer.hpp"
- (("defined\\(__MACH__\\)")
- "(defined __MACH__ && !defined __GNU__)"))
- #t)
- '())
+ (substitute* "boost/test/utils/timer.hpp"
+ (("defined\\(__MACH__\\)")
+ "(defined __MACH__ && !defined __GNU__)"))
(invoke "./bootstrap.sh"
(string-append "--prefix=" out)