summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-20 23:20:26 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-21 02:50:16 +0100
commitfd90e396953144570ebbc0dfabb516c8d4d51e72 (patch)
treecb300bbe45e7b8f076c53514ae06394d7c4a227c /gnu/packages/bittorrent.scm
parent782c94fe30268ef321dc32d313c96e33c4189b24 (diff)
downloadguix-patches-fd90e396953144570ebbc0dfabb516c8d4d51e72.tar
guix-patches-fd90e396953144570ebbc0dfabb516c8d4d51e72.tar.gz
gnu: mktorrent: Update to 1.1.
* gnu/packages/bittorrent.scm (mktorrent): Update to 1.1. [source, home-page]: Use new URI.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 053988c8db..1c6e512487 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Tomáš Čech <sleep_walker@gnu.org>
-;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
;;;
;;; This file is part of GNU Guix.
@@ -340,14 +340,15 @@ downloads, download scheduling, download rate limiting.")
(define-public mktorrent
(package
(name "mktorrent")
- (version "1.0")
+ (version "1.1")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/mktorrent/mktorrent/"
- version "/" name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (uri (string-append "https://github.com/Rudde/mktorrent/archive/v"
+ version ".tar.gz"))
(sha256
(base32
- "17qi3nfky240pq6qcmf5qg324mxm83vk9r3nvsdhsvinyqm5d3kg"))))
+ "1j9qc4fxa9isnaygqk6jazsiklqywl2wcs95b8dx01963407bx6h"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -359,7 +360,7 @@ downloads, download scheduling, download rate limiting.")
"USE_LONG_OPTIONS=1"
"USE_PTHREADS=1")
#:tests? #f)) ; no tests
- (home-page "http://mktorrent.sourceforge.net/")
+ (home-page "https://github.com/Rudde/mktorrent")
(synopsis "Utility to create BitTorrent metainfo files")
(description "mktorrent is a simple command-line utility to create
BitTorrent @dfn{metainfo} files, often known simply as @dfn{torrents}, from