summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-24 22:00:58 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-24 22:01:08 +0100
commitdf66fee79aad663897f27b2aac9933f4338b4f5f (patch)
tree444320f9a27370712a5d230fb948fb286eca45dd /gnu/packages/bittorrent.scm
parente8435c4d289107d240c395dd636363297bb15cb5 (diff)
downloadguix-patches-df66fee79aad663897f27b2aac9933f4338b4f5f.tar
guix-patches-df66fee79aad663897f27b2aac9933f4338b4f5f.tar.gz
gnu: Add libTorrent.
* gnu/packages/bittorrent.scm (libtorrent): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 8b4388668e..24b6ccb4d3 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -30,7 +31,8 @@
#:use-module ((gnu packages compression)
#:select (zlib))
#:use-module (gnu packages glib)
- #:use-module (gnu packages gtk))
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages check))
(define-public transmission
(package
@@ -88,3 +90,34 @@ DHT, µTP, PEX and Magnet Links.")
;;
;; A few files files carry an MIT/X11 license header.
(license l:gpl3+)))
+
+(define-public libtorrent
+ (package
+ (name "libtorrent")
+ (version "0.13.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://libtorrent.rakshasa.no/downloads/libtorrent-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ma910br5vxrfpm4f4w4942lpmhwvqjnnf9h8vpf52fw35qhjkkh"))))
+ (build-system gnu-build-system)
+ (inputs `(("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ;; Add this when you enable tests:
+ ;; ("cppunit" ,cppunit)
+ ))
+ (arguments
+ ;; FIXME: enable tests on the next release:
+ ;; https://github.com/rakshasa/libtorrent/issues/59
+ `(#:tests? #f))
+ (synopsis "BitTorrent library of rtorrent")
+ (description
+ "LibTorrent is a BitTorrent library used by and developed in parallel
+with the BitTorrent client rtorrent. It is written in C++ with emphasis on
+speed and efficiency.")
+ (home-page "http://libtorrent.rakshasa.no/")
+ (license l:gpl2+)))