summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-08-16 11:07:27 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-16 11:07:27 +0200
commitc16341bb9e6bc6751473668afee5022eb287b1e1 (patch)
tree74fa3f4f04f6f66bd36fcabd7cee7150bf7a6822 /gnu/packages/bittorrent.scm
parentfc4b13ee822dd7a493cac82052c14590d7351536 (diff)
downloadguix-patches-c16341bb9e6bc6751473668afee5022eb287b1e1.tar
guix-patches-c16341bb9e6bc6751473668afee5022eb287b1e1.tar.gz
gnu: bittorrent: Disable tests.
* gnu/packages/bittorrent.scm (bittorrent)[arguments]: Disable tests that are failing when using libevent 2.12 without internet connection.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index e17e04dcfe..46ff706e3e 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -90,6 +90,10 @@
(list (string-append "--localedir="
(assoc-ref %outputs "gui")
"/share/locale"))
+ ;; Some tests segfault when using libevent 2.12 without internet
+ ;; connection. This has been reported mainstream but not fixed yet:
+ ;; https://github.com/transmission/transmission/issues/1437.
+ #:tests? #f
#:glib-or-gtk-wrap-excluded-outputs '("out")
#:phases
(modify-phases %standard-phases