summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-04-02 11:00:02 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-04-02 11:00:02 +0200
commitbf155ce30cd417f8dba9ab04c1d39cc3249bb930 (patch)
tree4bc7d90daf517d88a29217c495d48e36249536b0 /gnu/packages/bittorrent.scm
parente7228f0cfaf7b09f895111886a4df6aa53812ecd (diff)
downloadguix-patches-bf155ce30cd417f8dba9ab04c1d39cc3249bb930.tar
guix-patches-bf155ce30cd417f8dba9ab04c1d39cc3249bb930.tar.gz
gnu: transmission: Install icons to the "gui" output.
* gnu/packages/bittorrent.scm (transmission)[arguments]: Move the "icons" and "pixmaps" folders to the "gui" output. Previously, if the user only install the "gui" output, the icon would be missing.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 0f63c3d0f2..03c7fe4515 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -94,10 +94,13 @@
(string-append gui
"/bin/transmission-gtk"))
- ;; Move the '.desktop' file as well.
+ ;; Move the '.desktop' and icon files as well.
(mkdir (string-append gui "/share"))
- (rename-file (string-append out "/share/applications")
- (string-append gui "/share/applications")))
+ (for-each
+ (lambda (dir)
+ (rename-file (string-append out "/share/" dir)
+ (string-append gui "/share/" dir)))
+ '("applications" "icons" "pixmaps")))
#t)))))
(inputs
`(("inotify-tools" ,inotify-tools)