summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorJustin Veilleux <justun1011@gmail.com>2021-07-16 12:01:41 -0400
committerLeo Famulari <leo@famulari.name>2021-07-16 23:53:46 -0400
commit9cb35c02164d929fcb8929e7f454df215df8cf25 (patch)
tree3265c5c499e51e8ecb86999181ec1343e2f1af79 /gnu/packages/bittorrent.scm
parent3ee0f170c8bd883728d8abb2c2e00f445c13f17d (diff)
downloadguix-patches-9cb35c02164d929fcb8929e7f454df215df8cf25.tar
guix-patches-9cb35c02164d929fcb8929e7f454df215df8cf25.tar.gz
gnu: Add transmission-remote-gtk.
* gnu/packages/bittorrent.scm (transmission-remote-gtk): New variable. * gnu/packages/patches/transmission-remote-gtk-fix-appstream.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Co-authored-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 0ca60d607c..e17e04dcfe 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages adns)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -45,6 +47,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
@@ -138,6 +141,35 @@ DHT, µTP, PEX and Magnet Links.")
;; A few files files carry an MIT/X11 license header.
(license (list l:gpl2 l:gpl3))))
+(define-public transmission-remote-gtk
+ (package
+ (name "transmission-remote-gtk")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/transmission-remote-gtk/"
+ "transmission-remote-gtk/releases/download/"
+ version "/transmission-remote-gtk-" version
+ ".tar.xz"))
+ (patches (search-patches "transmission-remote-gtk-fix-appstream.patch"))
+ (sha256
+ (base32 "1aqjl5rgamgcgqvcldd1gzyfh2xci0m7070924d6vz2qln0q75sr"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gnu-gettext)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("appstream-glib" ,appstream-glib)
+ ("curl" ,curl)
+ ("gtk+" ,gtk+)
+ ("json-glib" ,json-glib)))
+ (synopsis "Gtk frontend to the Transmission daemon")
+ (description "transmission-remote-gtk is a GTK client for remote management
+of the Transmission BitTorrent client, using its HTTP RPC protocol.")
+ (home-page "https://github.com/transmission-remote-gtk/transmission-remote-gtk")
+ (license l:gpl2+)))
+
(define-public libtorrent
(package
(name "libtorrent")