summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-15 16:07:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-15 20:10:21 +0200
commit96e2ecb7961dce9684e5adad2639db2aac66f51b (patch)
tree1d35da675812bb913695ac39f508dea86f4cc78c /gnu/packages/bittorrent.scm
parent591ee071c66e676dd0f8ff3e836124daa1a7b7f7 (diff)
downloadguix-patches-96e2ecb7961dce9684e5adad2639db2aac66f51b.tar
guix-patches-96e2ecb7961dce9684e5adad2639db2aac66f51b.tar.gz
gnu: tremc: Update to 0.9.1.
* gnu/packages/bittorrent.scm (tremc): Update to 0.9.1. [source]: Use release tag.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm60
1 files changed, 28 insertions, 32 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index d29c3f6894..4d1d141e4a 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -179,39 +179,35 @@ XML-RPC over SCGI.")
(license l:gpl2+)))
(define-public tremc
- (let ((commit "e06d08d8d76aa0559593ffc1188f4a90100cdbdb")
- (revision "2"))
- (package
- (name "tremc")
- (version (git-version "0.9.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/louipc/tremc.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "17rf74sajcn5fl718rgl2qk5mw5yz9hrh58hbcg4p55wrazzrm1i"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no test suite
- #:make-flags
- (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- ;; The software is just a Python script that must be copied into
- ;; place.
- (delete 'configure)
- (delete 'build))))
- (inputs
- `(("python" ,python)))
- (synopsis "Console client for the Transmission BitTorrent daemon")
- (description "Tremc is a console client, with a curses interface, for the
+ (package
+ (name "tremc")
+ (version "0.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/louipc/tremc.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yhwvlcyv1s830p5a7q5x3mkb3mbvr5cn5nh7y62l5b6iyyynlvm"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ ;; The software is just a Python script that must be copied into place.
+ (delete 'configure)
+ (delete 'build))))
+ (inputs
+ `(("python" ,python)))
+ (synopsis "Console client for the Transmission BitTorrent daemon")
+ (description "Tremc is a console client, with a curses interface, for the
Transmission BitTorrent daemon.")
- (home-page "https://github.com/louipc/tremc")
- (license l:gpl3+))))
+ (home-page "https://github.com/louipc/tremc")
+ (license l:gpl3+)))
(define-public transmission-remote-cli
(package