summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/bittorrent.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm88
1 files changed, 36 insertions, 52 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 3f69d7e8d2..0dcb1ee991 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -122,14 +122,9 @@
(string-append gui "/share/man/man1/transmission-gtk.1"))
#t))))))
(inputs
- `(("libevent" ,libevent)
- ("curl" ,curl)
- ("openssl" ,openssl)
- ("zlib" ,zlib)
- ("gtk+" ,gtk+)))
+ (list libevent curl openssl zlib gtk+))
(native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ (list intltool pkg-config))
(home-page "https://transmissionbt.com/")
(synopsis "Fast and easy BitTorrent client")
(description
@@ -163,13 +158,9 @@ DHT, µTP, PEX and Magnet Links.")
(base32 "0qz9wi70qc6vgnaymivc3xz6y86c9hglk6wjv3snnqxpxmp9saay"))))
(build-system gnu-build-system)
(native-inputs
- `(("gettext" ,gnu-gettext)
- ("pkg-config" ,pkg-config)))
+ (list gnu-gettext pkg-config))
(inputs
- `(("appstream-glib" ,appstream-glib)
- ("curl" ,curl)
- ("gtk+" ,gtk+)
- ("json-glib" ,json-glib)))
+ (list appstream-glib curl gtk+ json-glib))
(synopsis "Gtk frontend to the Transmission daemon")
(description "transmission-remote-gtk is a GTK client for remote management
of the Transmission BitTorrent client, using its HTTP RPC protocol.")
@@ -189,10 +180,8 @@ of the Transmission BitTorrent client, using its HTTP RPC protocol.")
(base32
"10z9i1rc41cmmi7nx8k7k1agsx6afv09g9cl7g9zr35fyhl5l4gd"))))
(build-system gnu-build-system)
- (inputs `(("openssl" ,openssl)
- ("zlib" ,zlib)))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("cppunit" ,cppunit)))
+ (inputs (list openssl zlib))
+ (native-inputs (list pkg-config cppunit))
(synopsis "BitTorrent library of rtorrent")
(description
"LibTorrent is a BitTorrent library used by and developed in parallel
@@ -214,14 +203,13 @@ speed and efficiency.")
(base32
"1bs2fnf4q7mlhkhzp3i1v052v9xn8qa7g845pk9ia8hlpw207pwy"))))
(build-system gnu-build-system)
- (inputs `(("libtorrent" ,libtorrent)
- ("ncurses" ,ncurses)
- ("curl" ,curl)
- ("cyrus-sasl" ,cyrus-sasl)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("cppunit" ,cppunit)))
+ (inputs (list libtorrent
+ ncurses
+ curl
+ cyrus-sasl
+ openssl
+ zlib))
+ (native-inputs (list pkg-config cppunit))
(synopsis "BitTorrent client with ncurses interface")
(description
"rTorrent is a BitTorrent client with an ncurses interface. It supports
@@ -255,7 +243,7 @@ XML-RPC over SCGI.")
(delete 'configure)
(delete 'build))))
(inputs
- `(("python" ,python)))
+ (list python))
(synopsis "Console client for the Transmission BitTorrent daemon")
(description "Tremc is a console client, with a curses interface, for the
Transmission BitTorrent daemon.")
@@ -334,17 +322,17 @@ maintained upstream.")
(string-append "// " text)))
#t)))))
(native-inputs
- `(("cppunit" ,cppunit) ; for the tests
- ("pkg-config" ,pkg-config)))
+ (list cppunit ; for the tests
+ pkg-config))
(inputs
- `(("c-ares" ,c-ares)
- ("gnutls" ,gnutls)
- ("gmp" ,gmp)
- ("libssh2" ,libssh2)
- ("libxml2" ,libxml2)
- ("nettle" ,nettle)
- ("sqlite" ,sqlite)
- ("zlib" ,zlib)))
+ (list c-ares
+ gnutls
+ gmp
+ libssh2
+ libxml2
+ nettle
+ sqlite
+ zlib))
(home-page "https://aria2.github.io/")
(synopsis "Utility for parallel downloading files")
(description
@@ -369,17 +357,16 @@ Aria2 can be manipulated via built-in JSON-RPC and XML-RPC interfaces.")
(arguments
`(#:configure-flags '("CFLAGS=-fcommon")))
(inputs
- `(("curl" ,curl)
- ("gtk+" ,gtk+)
- ("glib" ,glib)
- ("gnutls" ,gnutls)
- ("gstreamer" ,gstreamer)
- ("libgcrypt" ,libgcrypt)
- ("libnotify" ,libnotify)
- ("openssl" ,openssl)))
+ (list curl
+ gtk+
+ glib
+ gnutls
+ gstreamer
+ libgcrypt
+ libnotify
+ openssl))
(native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ (list intltool pkg-config))
(home-page "https://ugetdm.com/")
(synopsis "Universal download manager with GTK+ interface")
(description
@@ -459,8 +446,7 @@ and will take advantage of multiple processor cores where possible.")
"-j" (if parallel-tests?
(number->string (parallel-job-count))
"1")))))))))
- (inputs `(("boost" ,boost)
- ("openssl" ,openssl)))
+ (inputs (list boost openssl))
(native-inputs `(("libfaketime" ,libfaketime)
("python" ,python-wrapper)
("pkg-config" ,pkg-config)))
@@ -506,8 +492,7 @@ desktops.")
(wrap-qt-program "qbittorrent" #:output out #:inputs inputs))
#t)))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("qttools" ,qttools)))
+ (list pkg-config qttools))
(inputs
`(("boost" ,boost)
("libtorrent-rasterbar" ,libtorrent-rasterbar)
@@ -560,8 +545,7 @@ features.")
("python-twisted" ,python-twisted)
("python-zope-interface" ,python-zope-interface)))
(native-inputs
- `(("intltool" ,intltool)
- ("python-wheel" ,python-wheel)))
+ (list intltool python-wheel))
;; TODO: Enable tests.
;; After "pytest-twisted" is packaged, HOME is set, and an X server is
;; started, some of the tests still fail. There are likely some tests