summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-07 11:18:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-07 11:37:21 +0300
commit7b6a8e23b0de18262a42e44432f955517d71d796 (patch)
treefd970bff2fa436e9e434a6b36e3a7166d967b163 /gnu/packages/bittorrent.scm
parentd3e22bcc1141cd33dde7017f51058f18d428917c (diff)
downloadguix-patches-7b6a8e23b0de18262a42e44432f955517d71d796.tar
guix-patches-7b6a8e23b0de18262a42e44432f955517d71d796.tar.gz
gnu: aria2: Update to 1.35.0.
* gnu/packages/bittorrent.scm (aria2): Update to 1.35.0. [source]: Use new upstream uri. Remove patch. * gnu/packages/patches/aria2-CVE-2019-3500.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 50b63048e4..da01848ec7 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
@@ -262,16 +262,15 @@ maintained upstream.")
(define-public aria2
(package
(name "aria2")
- (version "1.34.0")
+ (version "1.35.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/tatsuhiro-t/aria2/"
- "releases/download/release-" version "/"
- name "-" version ".tar.xz"))
- (patches (search-patches "aria2-CVE-2019-3500.patch"))
+ (uri (string-append "https://github.com/aria2/aria2/releases/"
+ "download/release-" version
+ "/aria2-" version ".tar.xz"))
(sha256
(base32
- "18vpgr430vxlwbcc3598rr1srfmwypls6wp1m4wf21hncc1ahi1s"))))
+ "1zbxc517d97lb96f15xcy4l7b66grxrp3h2ids2jiwkaip87yaqy"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list "--enable-libaria2"