summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-17 04:28:24 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-17 18:43:21 +0100
commit0748a7b2d758c7ce1437389a1d89e1a3b443ab74 (patch)
tree7551af8d7305770174adb68cbc82ab69a5a040f5 /gnu/packages/bittorrent.scm
parent71fb3263ae274a663240627901ce6cbedbbd81d4 (diff)
downloadguix-patches-0748a7b2d758c7ce1437389a1d89e1a3b443ab74.tar
guix-patches-0748a7b2d758c7ce1437389a1d89e1a3b443ab74.tar.gz
gnu: qbittorrent: Don't use unstable tarball.
* gnu/packages/bittorrent.scm (qbittorrent)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index edb3e51d11..d96610a791 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -427,15 +427,15 @@ desktops.")
(package
(name "qbittorrent")
(version "4.1.5")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/qbittorrent/qBittorrent/archive/release-"
- version ".tar.gz"))
- (file-name (string-append name "-release-" version ".tar.gz"))
- (sha256
- (base32
- "0b0xy48szhbdljvy1c92rj31kdh0jpc4v4sni5gz9nd7430dkivn"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/qbittorrent/qBittorrent.git")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09zcygaxfv9g6av0vsvlyzv4v65wvj766xyfx31yz5ig3xan6ak1"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags