summaryrefslogtreecommitdiff
path: root/gnu/packages/bison.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-30 09:48:18 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-30 09:49:34 +0200
commit8d564b8b81b98fec9aac2f5f2d3cb0d1f2ea1416 (patch)
tree8c1987ed2a75933301e485174f9a872c689d0d6e /gnu/packages/bison.scm
parent737c83f0ff9977572516c65502bdde92abd18629 (diff)
downloadguix-patches-8d564b8b81b98fec9aac2f5f2d3cb0d1f2ea1416.tar
guix-patches-8d564b8b81b98fec9aac2f5f2d3cb0d1f2ea1416.tar.gz
gnu: xyce: Use Bison 3.0.
Xyce requires Bison 3.0 at the latest. * gnu/packages/bison.scm (bison-3.0): New variable. * gnu/packages/engineering.scm (xyce-serial)[native-inputs]: Use BISON-3.0 instead of BISON.
Diffstat (limited to 'gnu/packages/bison.scm')
-rw-r--r--gnu/packages/bison.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/bison.scm b/gnu/packages/bison.scm
index 5ebc883d53..12f19b785e 100644
--- a/gnu/packages/bison.scm
+++ b/gnu/packages/bison.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2015, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
@@ -63,3 +63,16 @@ deterministic or generalized LR parser from an annotated, context-free
grammar. It is versatile enough to have many applications, from parsers for
simple tools through complex programming languages.")
(license gpl3+)))
+
+(define-public bison-3.0
+ (package
+ (inherit bison)
+ (version "3.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/bison/bison-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0f7kjygrckkx8vas2nm673592jif0a9mw5g8207f6hj6h4pfyp07"))))))