summaryrefslogtreecommitdiff
path: root/gnu/packages/bison.scm
diff options
context:
space:
mode:
authorB. Wilson <elaexuotee@wilsonb.com>2020-06-19 23:08:40 +0900
committerMathieu Othacehe <othacehe@gnu.org>2020-06-21 11:06:53 +0200
commit512d23c65d82bb874ca1fb3c12095b1cec8bbfca (patch)
tree4f776e798e15276e04444e03790026e6f01d7cef /gnu/packages/bison.scm
parent292b26d4e598ba00d88f9a0498acc359ea338326 (diff)
downloadguix-patches-512d23c65d82bb874ca1fb3c12095b1cec8bbfca.tar
guix-patches-512d23c65d82bb874ca1fb3c12095b1cec8bbfca.tar.gz
gnu: Add poke.
* gnu/packages/engineering.scm (poke): New variable. * gnu/packages/bison.scm (bison-3.6): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/bison.scm')
-rw-r--r--gnu/packages/bison.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/bison.scm b/gnu/packages/bison.scm
index ae8d1a141b..63b14c7059 100644
--- a/gnu/packages/bison.scm
+++ b/gnu/packages/bison.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2012, 2013, 2015, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -64,6 +65,18 @@ grammar. It is versatile enough to have many applications, from parsers for
simple tools through complex programming languages.")
(license gpl3+)))
+(define-public bison-3.6
+ (package
+ (inherit bison)
+ (name "bison-3.6")
+ (version "3.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/bison/bison-" version ".tar.xz"))
+ (sha256
+ (base32 "0gdpnjh6ra9xa9vj6hzjdf0c04x4pjyy8vssm3qdb7fya4v7knq6"))))))
+
(define-public bison-3.0
(package
(inherit bison)