summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-11 19:53:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-11 20:01:53 +0100
commitfb94174fc39cfbdddf23aa58a12b1ee62674122d (patch)
tree63557e6b09352c8171f97b02f710613232018bd7 /gnu/packages/bioinformatics.scm
parent531afc8a892512487251a03be24d9833b86179f1 (diff)
downloadguix-patches-fb94174fc39cfbdddf23aa58a12b1ee62674122d.tar
guix-patches-fb94174fc39cfbdddf23aa58a12b1ee62674122d.tar.gz
gnu: Add pigx-bsseq.
* gnu/packages/bioinformatics.scm (pigx-bsseq): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 50d3568987..567dd2c24b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12791,3 +12791,67 @@ addition to quality control of the experiment, the pipeline enables to set up
multiple peak calling analysis and allows the generation of a UCSC track hub
in an easily configurable manner.")
(license license:gpl3+)))
+
+(define-public pigx-bsseq
+ (package
+ (name "pigx-bsseq")
+ (version "0.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/BIMSBbioinfo/pigx_bsseq/"
+ "releases/download/v" version
+ "/pigx_bsseq-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1h8ma99vi7hs83nafvjpq8jmaq9977j3n11c4zd95hai0cf7zxmp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-timezone
+ ;; The readr package is picky about timezones.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "TZ" "UTC+1")
+ (setenv "TZDIR"
+ (string-append (assoc-ref inputs "tzdata")
+ "/share/zoneinfo"))
+ #t))
+ (add-after 'install 'wrap-executable
+ ;; Make sure the executable finds all R modules.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/pigx-bsseq")
+ `("R_LIBS_SITE" ":" = (,(getenv "R_LIBS_SITE")))
+ `("PYTHONPATH" ":" = (,(getenv "PYTHONPATH")))))
+ #t)))))
+ (native-inputs
+ `(("tzdata" ,tzdata)))
+ (inputs
+ `(("r-minimal" ,r-minimal)
+ ("r-annotationhub" ,r-annotationhub)
+ ("r-dt" ,r-dt)
+ ("r-genomation" ,r-genomation)
+ ("r-methylkit" ,r-methylkit)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-bookdown" ,r-bookdown)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-ggbio" ,r-ggbio)
+ ("ghc-pandoc" ,ghc-pandoc)
+ ("ghc-pandoc-citeproc" ,ghc-pandoc-citeproc)
+ ("python-wrapper" ,python-wrapper)
+ ("python-pyyaml" ,python-pyyaml)
+ ("snakemake" ,snakemake)
+ ("bismark" ,bismark)
+ ("fastqc" ,fastqc)
+ ("bowtie" ,bowtie)
+ ("trim-galore" ,trim-galore)
+ ("cutadapt" ,cutadapt)
+ ("samtools" ,samtools)))
+ (home-page "http://bioinformatics.mdc-berlin.de/pigx/")
+ (synopsis "Bisulfite sequencing pipeline from fastq to methylation reports")
+ (description "PiGx BSseq is a data processing pipeline for raw fastq read
+data of bisulfite experiments; it produces reports on aggregate methylation
+and coverage and can be used to produce information on differential
+methylation and segmentation.")
+ (license license:gpl3+)))