summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-23 15:52:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-23 15:53:51 +0200
commitf1f17c7bba778ec03a5e40a34591564684461df5 (patch)
tree97a1cd98ed5c9e0e046a95239d7a9092920830cf /gnu/packages/bioinformatics.scm
parenta9b01b758213fe5854f305ebc767cde01794f6c6 (diff)
downloadguix-patches-f1f17c7bba778ec03a5e40a34591564684461df5.tar
guix-patches-f1f17c7bba778ec03a5e40a34591564684461df5.tar.gz
gnu: Add shorah.
* gnu/packages/bioinformatics.scm (shorah): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a3dd76c3bd..0aaf30872e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7601,6 +7601,64 @@ Perl and can be helpful if you want to filter, reformat, or trim your sequence
data. It also generates basic statistics for your sequences.")
(license license:gpl3+)))
+(define-public shorah
+ (package
+ (name "shorah")
+ (version "1.99.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/cbg-ethz/shorah"
+ "/releases/download/v" version
+ "/shorah-" version ".tar.xz"))
+ (sha256
+ (base32
+ "158dir9qcqspknlnyfr9zwk41x48nrh5wcg10k2grh9cidp9daiq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-test-wrapper
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (substitute* "examples/run_end2end_test"
+ (("\\$\\{interpreter\\} ../\\$\\{testscript\\}")
+ (string-append bin "/${testscript}"))))))
+ (delete 'check)
+ (add-after 'install 'wrap-programs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (site (string-append
+ out "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages"))
+ (pythonpath (getenv "PYTHONPATH"))
+ (script (string-append out "/bin/shorah")))
+ (chmod script #o555)
+ (wrap-program script `("PYTHONPATH" ":" prefix (,site ,pythonpath))))))
+ (add-after 'wrap-programs 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "check")))))))
+ (inputs
+ `(("boost" ,boost)
+ ("htslib" ,htslib)
+ ("python" ,python)
+ ("python-biopython" ,python-biopython)
+ ("python-numpy" ,python-numpy)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "")
+ (synopsis "Short reads assembly into haplotypes")
+ (description
+ "ShoRAH is a project for the analysis of next generation sequencing data.
+It is designed to analyse genetically heterogeneous samples. Its tools
+provide error correction, haplotype reconstruction and estimation of the
+frequency of the different genetic variants present in a mixed sample.")
+ (license license:gpl3+)))
+
(define-public ruby-bio-kseq
(package
(name "ruby-bio-kseq")