summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorPjotr Prins <pjotr.public12@thebird.nl>2015-09-17 06:17:44 +0000
committerDavid Thompson <dthompson2@worcester.edu>2015-09-19 12:41:52 -0400
commitedb15985f1123e54199bac7228e49fb84371e0cb (patch)
tree32528fb10331c242da8522181aa8069cd9afe872 /gnu/packages/bioinformatics.scm
parent28c5d42d354c6e902529d3c6e55138ee942461d0 (diff)
downloadguix-patches-edb15985f1123e54199bac7228e49fb84371e0cb.tar
guix-patches-edb15985f1123e54199bac7228e49fb84371e0cb.tar.gz
gnu: Add bioruby.
* gnu/packages/bioinformatics.scm (bioruby): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a13fd7a91d..37bd3339d3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2700,3 +2700,46 @@ position for indels. Bio-locus allows users to store this chr+pos or
chr+pos+alt information in a database.")
(home-page "https://github.com/pjotrp/bio-locus")
(license license:expat)))
+
+(define-public bioruby
+ (package
+ (name "bioruby")
+ (version "1.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "bio" version))
+ (sha256
+ (base32
+ "01k2fyjl5fpx4zn8g6gqiqvsg2j1fgixrs9p03vzxckynxdq3wmc"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-libxml" ,ruby-libxml)))
+ (native-inputs
+ `(("which" ,which))) ; required for test phase
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-test-command
+ (lambda _
+ (substitute* '("test/functional/bio/test_command.rb")
+ (("/bin/sh") (which "sh")))
+ (substitute* '("test/functional/bio/test_command.rb")
+ (("/bin/ls") (which "ls")))
+ (substitute* '("test/functional/bio/test_command.rb")
+ (("which") (which "which")))
+ (substitute* '("test/functional/bio/test_command.rb",
+ "test/data/command/echoarg2.sh")
+ (("/bin/echo") (which "echo")))
+ #t)))))
+ (synopsis "Ruby library, shell and utilities for bioinformatics")
+ (description "BioRuby comes with a comprehensive set of Ruby development
+tools and libraries for bioinformatics and molecular biology. BioRuby has
+components for sequence analysis, pathway analysis, protein modelling and
+phylogenetic analysis; it supports many widely used data formats and provides
+easy access to databases, external programs and public web services, including
+BLAST, KEGG, GenBank, MEDLINE and GO.")
+ (home-page "http://bioruby.org/")
+ ;; Code is released under Ruby license, except for setup
+ ;; (LGPLv2.1+) and scripts in samples (which have GPL2 and GPL2+)
+ (license (list license:ruby license:lgpl2.1+ license:gpl2+ ))))