summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-06 15:42:02 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-09 10:26:28 +0100
commitd7678942f9a4a4f046e0781ab89ce62680ded24c (patch)
treef047f4df1ca2db1c7b8559f5cb438b2055d2d978 /gnu/packages/bioinformatics.scm
parentd3517eda25c74758ddedb04fa781aa65549248fe (diff)
downloadguix-patches-d7678942f9a4a4f046e0781ab89ce62680ded24c.tar
guix-patches-d7678942f9a4a4f046e0781ab89ce62680ded24c.tar.gz
gnu: Add flexbar.
* gnu/packages/bioinformatics.scm (flexbar): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0cae8274d5..c0d14388e1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -21,6 +21,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages base)
@@ -29,6 +30,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python))
+ #:use-module (gnu packages tbb)
(define-public bedtools
(package
@@ -139,6 +141,46 @@ gapped, local, and paired-end alignment modes.")
(supported-systems '("x86_64-linux"))
(license license:gpl3+)))
+(define-public flexbar
+ (package
+ (name "flexbar")
+ (version "2.5")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://sourceforge/flexbar/"
+ version "/flexbar_v" version "_src.tgz"))
+ (sha256
+ (base32
+ "13jaykc3y1x8y5nn9j8ljnb79s5y51kyxz46hdmvvjj6qhyympmf"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(;; There is no test target, although there is a directory containing
+ ;; test data and scripts (launched by flexbar_validate.sh).
+ #:tests? #f
+ #:configure-flags (list
+ (string-append "-DFLEXBAR_BINARY_DIR="
+ (assoc-ref %outputs "out")
+ "/bin/"))
+ #:phases
+ (alist-delete 'install %standard-phases)))
+ (inputs
+ `(("tbb" ,tbb)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("seqan" ,seqan)))
+ (home-page "http://flexbar.sourceforge.net")
+ (synopsis "Barcode and adapter removal tool for sequencing platforms")
+ (description
+ "Flexbar preprocesses high-throughput nucleotide sequencing data
+efficiently. It demultiplexes barcoded runs and removes adapter sequences.
+Moreover, trimming and filtering features are provided. Flexbar increases
+read mapping rates and improves genome and transcriptome assemblies. It
+supports next-generation sequencing data in fasta/q and csfasta/q format from
+Illumina, Roche 454, and the SOLiD platform.")
+ (license license:gpl3)))
+
(define-public samtools
(package
(name "samtools")