summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-09-19 19:31:57 +1000
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-25 16:16:28 +0200
commitd708b7a9734e5a2b2bd9db6152b2584e01086517 (patch)
treece48cb1be4fd3497468eadad30b60e93941efc94 /gnu/packages/bioinformatics.scm
parent665ce1ebe548c71e9da54caeb62eca5f9f588d4d (diff)
downloadguix-patches-d708b7a9734e5a2b2bd9db6152b2584e01086517.tar
guix-patches-d708b7a9734e5a2b2bd9db6152b2584e01086517.tar.gz
gnu: Add seqmagick.
* gnu/packages/bioinformatics.scm (seqmagick): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2e31d85b2d..e647186ab3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2552,6 +2552,44 @@ manipulation, online and indexed string search, efficient I/O of
bioinformatics file formats, sequence alignment, and more.")
(license license:bsd-3)))
+(define-public seqmagick
+ (package
+ (name "seqmagick")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/s/seqmagick/seqmagick-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0cgn477n74gsl4qdaakrrhi953kcsd4q3ivk2lr18x74s3g4ma1d"))))
+ (build-system python-build-system)
+ (arguments
+ ;; python2 only, see https://github.com/fhcrc/seqmagick/issues/56
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ ;; Current test in setup.py does not work as of 0.6.1,
+ ;; so use nose to run tests instead for now. See
+ ;; https://github.com/fhcrc/seqmagick/issues/55
+ (replace 'check (lambda _ (zero? (system* "nosetests")))))))
+ (inputs
+ `(("python-biopython" ,python2-biopython)))
+ (native-inputs
+ `(("python-setuptools" ,python2-setuptools)
+ ("python-nose" ,python2-nose)))
+ (home-page "http://github.com/fhcrc/seqmagick")
+ (synopsis "Tools for converting and modifying sequence files")
+ (description
+ "Bioinformaticians often have to convert sequence files between formats
+and do little manipulations on them, and it's not worth writing scripts for
+that. Seqmagick is a utility to expose the file format conversion in
+BioPython in a convenient way. Instead of having a big mess of scripts, there
+is one that takes arguments.")
+ (license license:gpl3)))
+
(define-public star
(package
(name "star")