summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-27 22:13:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-27 22:15:25 +0100
commitaa649ae2311df88fb7118334d2d5b2222b8d7642 (patch)
treec9e80477bef8b619ece73661ddefa9ca3af2a0ce /gnu/packages/bioinformatics.scm
parentf4cbf11c655475f0f0c21b0a69ca5bbb2e460133 (diff)
downloadguix-patches-aa649ae2311df88fb7118334d2d5b2222b8d7642.tar
guix-patches-aa649ae2311df88fb7118334d2d5b2222b8d7642.tar.gz
gnu: pigx-scrnaseq: Fix Python module capture.
The build system expects all Python modules to be on PYTHONPATH. * gnu/packages/bioinformatics.scm (pigx-scrnaseq)[arguments]: Set PYTHONPATH variable in new build phase.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 39f4a20051..93be974f1f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11132,7 +11132,10 @@ methylation and segmentation.")
(modify-phases %standard-phases
(add-before 'bootstrap 'autoreconf
(lambda _
- (invoke "autoreconf" "-vif"))))))
+ (invoke "autoreconf" "-vif")))
+ (add-before 'configure 'set-PYTHONPATH
+ (lambda _
+ (setenv "PYTHONPATH" (getenv "GUIX_PYTHONPATH")))))))
(native-inputs
(list automake autoconf))
(inputs