summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2021-06-06 07:14:07 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-06-07 10:38:54 +0300
commita8c653f0fc2f63d34b7a0dd84aaa6d9a3f009de5 (patch)
treeba5fdefc42b7bf19fa01d347b21fd40d5c0fca34 /gnu/packages/bioinformatics.scm
parente05100aafd22a80fd2c600c7b14636f3dfef6c78 (diff)
downloadguix-patches-a8c653f0fc2f63d34b7a0dd84aaa6d9a3f009de5.tar
guix-patches-a8c653f0fc2f63d34b7a0dd84aaa6d9a3f009de5.tar.gz
gnu: python-hic2cool: Update to 0.8.3.
* gnu/packages/bioinformatics.scm (python-hic2cool): Update to 0.8.3. [source]: Download using git-fetch. [arguments]: Enable tests. Add phase to make test data writable. [propagated-inputs]: Add python-h5py, python-numpy, python-pandas, python-scipy. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 23 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1e38c6e0e7..2c1f0e7493 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11922,18 +11922,35 @@ pyGenomeTracks can make plots with or without Hi-C data.")
(define-public python-hic2cool
(package
(name "python-hic2cool")
- (version "0.4.2")
+ (version "0.8.3")
+ ;; pypi sources do not contain the test_data directory and no test can be
+ ;; run
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "hic2cool" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/4dn-dcic/hic2cool")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0xy6mhfns2lzib1kcr6419jjp6pmh0qx8z8na55lmiwn0ds8q9cl"))))
+ "0dlnf0qfcp4jrc1nyya32a035c13xicyq16bwfnwhbb9s47mz7gl"))))
(build-system python-build-system)
- (arguments '(#:tests? #f)) ; no tests included
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Two of the test-data files need to be writable.
+ (add-after 'unpack 'make-test-data-writable
+ (lambda _
+ (for-each make-file-writable
+ (list "test_data/hic2cool_0.4.2_single_res.cool"
+ "test_data/hic2cool_0.7.0_multi_res.mcool")))))))
(propagated-inputs
- `(("python-cooler" ,python-cooler)))
+ `(("python-cooler" ,python-cooler)
+ ("python-h5py" ,python-h5py)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-scipy" ,python-scipy)))
(home-page "https://github.com/4dn-dcic/hic2cool")
(synopsis "Converter for .hic and .cool files")
(description