summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-10-05 14:17:25 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-10-05 14:17:25 +0200
commit87c079d9b55afda249ddc1b11798a62547a2cbb6 (patch)
treea7a0dbcfd8c3fb8935e00cc44f8b514fa790975b /gnu/packages/bioinformatics.scm
parentde96ed11efdfb450ca45952aceda656a78d981c4 (diff)
parent3699ed63501a28629956ca60e198f5fafa57ad4e (diff)
downloadguix-patches-87c079d9b55afda249ddc1b11798a62547a2cbb6.tar
guix-patches-87c079d9b55afda249ddc1b11798a62547a2cbb6.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm347
1 files changed, 5 insertions, 342 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b22deb4750..cbb2649bb4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2018, 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018, 2019, 2020 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
@@ -4496,7 +4496,7 @@ sequencing tag position and orientation.")
(define-public mafft
(package
(name "mafft")
- (version "7.394")
+ (version "7.471")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4505,7 +4505,7 @@ sequencing tag position and orientation.")
(file-name (string-append name "-" version ".tgz"))
(sha256
(base32
- "0bacjkxfg944p5khhyh5rd4y7wkjc9qk4v2jjj442sqlq0f8ar7b"))))
+ "0r1973fx2scq4712zdqfy67wkzqj0c0bhrdy4jxhvq40mdxyry30"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no automated tests, though there are tests in the read me
@@ -4568,7 +4568,7 @@ sequencing tag position and orientation.")
("gawk" ,gawk)
("grep" ,grep)
("coreutils" ,coreutils)))
- (home-page "http://mafft.cbrc.jp/alignment/software/")
+ (home-page "https://mafft.cbrc.jp/alignment/software/")
(synopsis "Multiple sequence alignment program")
(description
"MAFFT offers a range of multiple alignment methods for nucleotide and
@@ -4576,7 +4576,7 @@ protein sequences. For instance, it offers L-INS-i (accurate; for alignment
of <~200 sequences) and FFT-NS-2 (fast; for alignment of <~30,000
sequences).")
(license (license:non-copyleft
- "http://mafft.cbrc.jp/alignment/software/license.txt"
+ "https://mafft.cbrc.jp/alignment/software/license.txt"
"BSD-3 with different formatting"))))
(define-public mash
@@ -10599,343 +10599,6 @@ EMBL-EBI GWAS catalog.")
visualizations for publication-quality multi-panel figures.")
(license license:gpl2+)))
-(define-public r-fithic
- (package
- (name "r-fithic")
- (version "1.14.0")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "FitHiC" version))
- (sha256
- (base32
- "1dffkdxm08wq4kjd9j2v2625x3p6vbrk33a2zx94pwpgkghr72yp"))))
- (properties `((upstream-name . "FitHiC")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-data-table" ,r-data-table)
- ("r-fdrtool" ,r-fdrtool)
- ("r-rcpp" ,r-rcpp)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://bioconductor.org/packages/FitHiC")
- (synopsis "Confidence estimation for intra-chromosomal contact maps")
- (description
- "Fit-Hi-C is a tool for assigning statistical confidence estimates to
-intra-chromosomal contact maps produced by genome-wide genome architecture
-assays such as Hi-C.")
- (license license:gpl2+)))
-
-(define-public r-hitc
- (package
- (name "r-hitc")
- (version "1.32.0")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "HiTC" version))
- (sha256
- (base32
- "1jx2pfa7sbdz7xi466lz1h5xv126g56z73n0a5l2wrq28k47qaxy"))))
- (properties `((upstream-name . "HiTC")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biostrings" ,r-biostrings)
- ("r-genomeinfodb" ,r-genomeinfodb)
- ("r-genomicranges" ,r-genomicranges)
- ("r-iranges" ,r-iranges)
- ("r-matrix" ,r-matrix)
- ("r-rcolorbrewer" ,r-rcolorbrewer)
- ("r-rtracklayer" ,r-rtracklayer)))
- (home-page "https://bioconductor.org/packages/HiTC")
- (synopsis "High throughput chromosome conformation capture analysis")
- (description
- "The HiTC package was developed to explore high-throughput \"C\" data
-such as 5C or Hi-C. Dedicated R classes as well as standard methods for
-quality controls, normalization, visualization, and further analysis are also
-provided.")
- (license license:artistic2.0)))
-
-(define-public r-hdf5array
- (package
- (name "r-hdf5array")
- (version "1.16.1")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "HDF5Array" version))
- (sha256
- (base32
- "01767v90nl0499jcicpxngbbs0af5p9c5aasi5va01w3v5bnqddn"))))
- (properties `((upstream-name . "HDF5Array")))
- (build-system r-build-system)
- (inputs
- `(("zlib" ,zlib)))
- (propagated-inputs
- `(("r-biocgenerics" ,r-biocgenerics)
- ("r-delayedarray" ,r-delayedarray)
- ("r-iranges" ,r-iranges)
- ("r-matrix" ,r-matrix)
- ("r-rhdf5" ,r-rhdf5)
- ("r-rhdf5lib" ,r-rhdf5lib)
- ("r-s4vectors" ,r-s4vectors)))
- (home-page "https://bioconductor.org/packages/HDF5Array")
- (synopsis "HDF5 back end for DelayedArray objects")
- (description "This package provides an array-like container for convenient
-access and manipulation of HDF5 datasets. It supports delayed operations and
-block processing.")
- (license license:artistic2.0)))
-
-(define-public r-rhdf5lib
- (package
- (name "r-rhdf5lib")
- (version "1.10.1")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "Rhdf5lib" version))
- (sha256
- (base32
- "0f45sqrvzj6x4mckalyp8366hm8v0rrmzklx3xd4gs6l2wallcn9"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Delete bundled binaries
- (delete-file-recursively "src/wininclude/")
- (delete-file-recursively "src/winlib-4.9.3/")
- (delete-file-recursively "src/winlib-8.3.0/")
- (delete-file "src/hdf5small_cxx_hl_1.10.6.tar.gz")
- #t))))
- (properties `((upstream-name . "Rhdf5lib")))
- (build-system r-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'do-not-use-bundled-hdf5
- (lambda* (#:key inputs #:allow-other-keys)
- (for-each delete-file '("configure" "configure.ac"))
- ;; Do not make other packages link with the proprietary libsz.
- (substitute* "R/zzz.R"
- ((" \"%s/libsz.a\"") ""))
- (with-directory-excursion "src"
- (invoke "tar" "xvf" (assoc-ref inputs "hdf5-source"))
- (rename-file (string-append "hdf5-" ,(package-version hdf5-1.10))
- "hdf5")
- ;; Remove timestamp and host system information to make
- ;; the build reproducible.
- (substitute* "hdf5/src/libhdf5.settings.in"
- (("Configured on: @CONFIG_DATE@")
- "Configured on: Guix")
- (("Uname information:.*")
- "Uname information: Linux\n")
- ;; Remove unnecessary store reference.
- (("C Compiler:.*")
- "C Compiler: GCC\n"))
- (rename-file "Makevars.in" "Makevars")
- (substitute* "Makevars"
- (("@ZLIB_LIB@") "-lz")
- (("@ZLIB_INCLUDE@") "")
- (("HDF5_CXX_LIB=.*")
- (string-append "HDF5_CXX_LIB="
- (assoc-ref inputs "hdf5") "/lib/libhdf5_cpp.a\n"))
- (("HDF5_LIB=.*")
- (string-append "HDF5_LIB="
- (assoc-ref inputs "hdf5") "/lib/libhdf5.a\n"))
- (("HDF5_CXX_INCLUDE=.*") "HDF5_CXX_INCLUDE=./hdf5/c++/src\n")
- (("HDF5_INCLUDE=.*") "HDF5_INCLUDE=./hdf5/src\n")
- (("HDF5_HL_INCLUDE=.*") "HDF5_HL_INCLUDE=./hdf5/hl/src\n")
- (("HDF5_HL_CXX_INCLUDE=.*") "HDF5_HL_CXX_INCLUDE=./hdf5/hl/c++/src\n")
- (("HDF5_HL_LIB=.*")
- (string-append "HDF5_HL_LIB="
- (assoc-ref inputs "hdf5") "/lib/libhdf5_hl.a\n"))
- (("HDF5_HL_CXX_LIB=.*")
- (string-append "HDF5_HL_CXX_LIB="
- (assoc-ref inputs "hdf5") "/lib/libhdf5_hl_cpp.a\n"))
- ;; szip is non-free software
- (("cp \"\\$\\{SZIP_LIB\\}.*") "")
- (("PKG_LIBS =.*") "PKG_LIBS = -lz -lhdf5\n")))
- #t)))))
- (inputs
- `(("zlib" ,zlib)))
- (propagated-inputs
- `(("hdf5" ,hdf5-1.10)))
- (native-inputs
- `(("hdf5-source" ,(package-source hdf5-1.10))
- ("r-knitr" ,r-knitr)))
- (home-page "https://bioconductor.org/packages/Rhdf5lib")
- (synopsis "HDF5 library as an R package")
- (description "This package provides C and C++ HDF5 libraries for use in R
-packages.")
- (license license:artistic2.0)))
-
-(define-public r-beachmat
- (package
- (name "r-beachmat")
- (version "2.4.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "beachmat" version))
- (sha256
- (base32
- "1vl6jbf9ia78cm4ikdb8vz04jv4b46zhvg5i006c63a9pzw7zhxi"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biocgenerics" ,r-biocgenerics)
- ("r-delayedarray" ,r-delayedarray)
- ("r-matrix" ,r-matrix)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://bioconductor.org/packages/beachmat")
- (synopsis "Compiling Bioconductor to handle each matrix type")
- (description "This package provides a consistent C++ class interface for a
-variety of commonly used matrix types, including sparse and HDF5-backed
-matrices.")
- (license license:gpl3)))
-
-(define-public r-singlecellexperiment
- (package
- (name "r-singlecellexperiment")
- (version "1.10.1")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "SingleCellExperiment" version))
- (sha256
- (base32
- "092wvk11n7pa234vlwhxm3gdi4k3sbnz1splhxalbdhz3jf02zfp"))))
- (properties
- `((upstream-name . "SingleCellExperiment")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biocgenerics" ,r-biocgenerics)
- ("r-s4vectors" ,r-s4vectors)
- ("r-summarizedexperiment" ,r-summarizedexperiment)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://bioconductor.org/packages/SingleCellExperiment")
- (synopsis "S4 classes for single cell data")
- (description "This package defines an S4 class for storing data from
-single-cell experiments. This includes specialized methods to store and
-retrieve spike-in information, dimensionality reduction coordinates and size
-factors for each cell, along with the usual metadata for genes and
-libraries.")
- (license license:gpl3)))
-
-(define-public r-scater
- (package
- (name "r-scater")
- (version "1.16.2")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "scater" version))
- (sha256
- (base32
- "1pa5wvgjb30rw1vsjwbnn07ss3sc5n8ck5d7khdby4r2s9177s33"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-beachmat" ,r-beachmat)
- ("r-biocgenerics" ,r-biocgenerics)
- ("r-biocneighbors" ,r-biocneighbors)
- ("r-biocparallel" ,r-biocparallel)
- ("r-biocsingular" ,r-biocsingular)
- ("r-delayedarray" ,r-delayedarray)
- ("r-delayedmatrixstats" ,r-delayedmatrixstats)
- ("r-ggbeeswarm" ,r-ggbeeswarm)
- ("r-ggplot2" ,r-ggplot2)
- ("r-matrix" ,r-matrix)
- ("r-rcpp" ,r-rcpp)
- ("r-rlang" ,r-rlang)
- ("r-s4vectors" ,r-s4vectors)
- ("r-singlecellexperiment" ,r-singlecellexperiment)
- ("r-summarizedexperiment" ,r-summarizedexperiment)
- ("r-viridis" ,r-viridis)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://github.com/davismcc/scater")
- (synopsis "Single-cell analysis toolkit for gene expression data in R")
- (description "This package provides a collection of tools for doing
-various analyses of single-cell RNA-seq gene expression data, with a focus on
-quality control.")
- (license license:gpl2+)))
-
-(define-public r-scran
- (package
- (name "r-scran")
- (version "1.16.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "scran" version))
- (sha256
- (base32
- "1gm4ys4aq8h1pn45k1rxk384wjyf55izivw8kgxbrflj6j4xvvsv"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-beachmat" ,r-beachmat)
- ("r-bh" ,r-bh)
- ("r-biocgenerics" ,r-biocgenerics)
- ("r-biocneighbors" ,r-biocneighbors)
- ("r-biocparallel" ,r-biocparallel)
- ("r-biocsingular" ,r-biocsingular)
- ("r-delayedarray" ,r-delayedarray)
- ("r-delayedmatrixstats" ,r-delayedmatrixstats)
- ("r-dqrng" ,r-dqrng)
- ("r-edger" ,r-edger)
- ("r-igraph" ,r-igraph)
- ("r-iranges" ,r-iranges)
- ("r-limma" ,r-limma)
- ("r-matrix" ,r-matrix)
- ("r-rcpp" ,r-rcpp)
- ("r-s4vectors" ,r-s4vectors)
- ("r-scater" ,r-scater)
- ("r-singlecellexperiment" ,r-singlecellexperiment)
- ("r-statmod" ,r-statmod)
- ("r-summarizedexperiment" ,r-summarizedexperiment)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://bioconductor.org/packages/scran")
- (synopsis "Methods for single-cell RNA-Seq data analysis")
- (description "This package implements a variety of low-level analyses of
-single-cell RNA-seq data. Methods are provided for normalization of
-cell-specific biases, assignment of cell cycle phase, and detection of highly
-variable and significantly correlated genes.")
- (license license:gpl3)))
-
-(define-public r-delayedmatrixstats
- (package
- (name "r-delayedmatrixstats")
- (version "1.10.1")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "DelayedMatrixStats" version))
- (sha256
- (base32
- "046sam0rz42ph0m7jz7v3bck7d3h2mp45gzywh5dvc1qkjq6fdxx"))))
- (properties
- `((upstream-name . "DelayedMatrixStats")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biocparallel" ,r-biocparallel)
- ("r-delayedarray" ,r-delayedarray)
- ("r-hdf5array" ,r-hdf5array)
- ("r-iranges" ,r-iranges)
- ("r-matrix" ,r-matrix)
- ("r-matrixstats" ,r-matrixstats)
- ("r-s4vectors" ,r-s4vectors)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://github.com/PeteHaitch/DelayedMatrixStats")
- (synopsis "Functions that apply to rows and columns of DelayedMatrix objects")
- (description
- "This package provides a port of the @code{matrixStats} API for use with
-@code{DelayedMatrix} objects from the @code{DelayedArray} package. It
-contains high-performing functions operating on rows and columns of
-@code{DelayedMatrix} objects, e.g. @code{colMedians}, @code{rowMedians},
-@code{colRanks}, @code{rowRanks}, @code{colSds}, and @code{rowSds}. Functions
-are optimized per data type and for subsetted calculations such that both
-memory usage and processing time is minimized.")
- (license license:expat)))
-
(define-public r-dropbead
(let ((commit "d746c6f3b32110428ea56d6a0001ce52a251c247")
(revision "2"))