summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-01-23 04:39:52 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-01-27 03:56:06 +0100
commit87858bc526a9d577760f55d05a51cb56630f845b (patch)
treeef5416147d5424e54898af1cd49433236a162d3a /gnu/packages/bioinformatics.scm
parent1e8da4cdefb089ac7d2453d71f72924540238d87 (diff)
downloadguix-patches-87858bc526a9d577760f55d05a51cb56630f845b.tar
guix-patches-87858bc526a9d577760f55d05a51cb56630f845b.tar.gz
gnu: ocaml: Switch to ocaml 4.09 by default.
Bap and earley cannot be updated as they do not support 4.09 yet. Bap requires the janestreet packages, which cannot be upgraded as no version supports 4.09 and 4.07 at the same time. Moreover, newer versions of the janestreet packages have a different dependency graph, which will require a whole new set of packages. We cannot simply use package-with-ocaml4.07 on them. * gnu/packages/ocaml.scm (ocaml-sqlite3, ocaml-ppx-tools, ocaml-gen) (ocaml-sedlex, ocaml-pcre, ocaml-expect, ocaml-ezjsonm, ocaml-uri) (ocaml-piqilib, ocaml-piqi, ocaml-charinfo-width, ocaml-zed) (ocaml-lambda-term, ocaml-utop, ocaml-ppx-inline-test, ocaml-earley) (ocaml-merlin, ocaml-gsl, ocaml-gsl-1, ocaml-sexplib0, ocaml-parsexp) (ocaml-sexplib, ocaml-base, ocaml-stdio, ocaml-ppxlib, ocaml-ppx-compare) (ocaml-fieldslib, ocaml-variantslib, ocaml-ppx-fields-conv) (ocaml-ppx-sexp-conv, ocaml-ppx-variants-conv, ocaml-ppx-custom-printf) (ocaml-bin-prot, ocaml-ppx-hash, ocaml-ppx-enumerate, ocaml-ppx-bench) (ocaml-ppx-here, ocaml-ppx-typerep, ocaml-ppx-sexp-value) (ocaml-ppx-sexp-message, ocaml-ppx-pipebang, ocaml-ppx-optional) (ocaml-ppx-optcomp, ocaml-ppx-fail, ocaml-ppx-let, ocaml-ppx-assert) (ocaml-ppx-expect, ocaml-ppx-js-style, ocaml-ppx-typerep-conv) (ocaml-ppx-base, ocaml-ppx-bin-prot, ocaml-ppx-jane) (ocaml-splittable-random, ocaml-configurator, ocaml-spawn, ocaml-core) (ocaml-core-kernel, ocaml-odoc, ocaml-fftw3, ocaml-lacaml): Rename to ... (ocaml4.07-sqlite3, ocaml4.07-ppx-tools, ocaml4.07-gen, ocaml4.07-sedlex) (ocaml4.07-pcre, ocaml4.07-expect, ocaml4.07-ezjsonm, ocaml4.07-uri) (ocaml4.07-piqilib, ocaml4.07-piqi, ocaml4.07-charinfo-width) (ocaml4.07-zed, ocaml4.07-lambda-term, ocaml4.07-utop) (ocaml4.07-ppx-inline-test, ocaml4.07-earley, ocaml4.07-merlin) (ocaml4.07-gsl, ocaml4.07-gsl-1, ocaml4.07-sexplib0, ocaml4.07-parsexp) (ocaml4.07-sexplib, ocaml4.07-base, ocaml4.07-stdio, ocaml4.07-ppxlib) (ocaml4.07-ppx-compare, ocaml4.07-fieldslib, ocaml4.07-variantslib) (ocaml4.07-ppx-fields-conv, ocaml4.07-ppx-sexp-conv) (ocaml4.07-ppx-variants-conv, ocaml4.07-ppx-custom-printf) (ocaml4.07-bin-prot, ocaml4.07-ppx-hash, ocaml4.07-ppx-enumerate) (ocaml4.07-ppx-bench, ocaml4.07-ppx-here, ocaml4.07-ppx-typerep) (ocaml4.07-ppx-sexp-value, ocaml4.07-ppx-sexp-message) (ocaml4.07-ppx-pipebang, ocaml4.07-ppx-optional, ocaml4.07-ppx-optcomp) (ocaml4.07-ppx-fail, ocaml4.07-ppx-let, ocaml4.07-ppx-assert) (ocaml4.07-ppx-expect, ocaml4.07-ppx-js-style) (ocaml4.07-ppx-typerep-conv, ocaml4.07-ppx-base, ocaml4.07-ppx-bin-prot) (ocaml4.07-ppx-jane, ocaml4.07-splittable-random) (ocaml4.07-configurator, ocaml4.07-spawn, ocaml4.07-core) (ocaml4.07-core-kernel, ocaml4.07-odoc, ocaml4.07-fftw3) (ocaml4.07-lacaml): ... to this and use ocaml 4.07. (bap, unison): Use ocaml-4.07. * gnu/packages/bioinformatics.scm (pplacer): Use ocaml-4.07.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e8dac2a12b..c71adbe98c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14626,21 +14626,23 @@ let before_space s =
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin")))
(copy-recursively "bin" bin))
- #t)))))
+ #t)))
+ #:ocaml ,ocaml-4.07
+ #:findlib ,ocaml4.07-findlib))
(inputs
`(("zlib" ,zlib "static")
("gsl" ,gsl)
- ("ocaml-ounit" ,ocaml-ounit)
- ("ocaml-batteries" ,ocaml-batteries)
- ("ocaml-camlzip" ,camlzip)
- ("ocaml-csv" ,ocaml-csv)
- ("ocaml-sqlite3" ,ocaml-sqlite3)
- ("ocaml-xmlm" ,ocaml-xmlm)
- ("ocaml-mcl" ,ocaml-mcl)
- ("ocaml-gsl" ,ocaml-gsl-1)))
+ ("ocaml-ounit" ,(package-with-ocaml4.07 ocaml-ounit))
+ ("ocaml-batteries" ,(package-with-ocaml4.07 ocaml-batteries))
+ ("ocaml-camlzip" ,(package-with-ocaml4.07 camlzip))
+ ("ocaml-csv" ,(package-with-ocaml4.07 ocaml-csv))
+ ("ocaml-sqlite3" ,ocaml4.07-sqlite3)
+ ("ocaml-xmlm" ,(package-with-ocaml4.07 ocaml-xmlm))
+ ("ocaml-mcl" ,(package-with-ocaml4.07 ocaml-mcl))
+ ("ocaml-gsl" ,ocaml4.07-gsl-1)))
(native-inputs
`(("cddlib-src" ,(package-source cddlib))
- ("ocamlbuild" ,ocamlbuild)
+ ("ocamlbuild" ,(package-with-ocaml4.07 ocamlbuild))
("pkg-config" ,pkg-config)))
(propagated-inputs
`(("pplacer-scripts" ,pplacer-scripts)))