summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-06-01 13:14:38 +0200
committerRoel Janssen <roel@gnu.org>2021-06-01 13:14:38 +0200
commit7ae2b1f2dcc35b1cb670cfa8c87b2d0a5779f5b9 (patch)
tree6d8be652982116b2d0cdcf437b6cdd35fefb7b3a /gnu/packages/bioinformatics.scm
parentb4e3b77270be9d6ff579429d5ced84b467f0f6a3 (diff)
downloadguix-patches-7ae2b1f2dcc35b1cb670cfa8c87b2d0a5779f5b9.tar
guix-patches-7ae2b1f2dcc35b1cb670cfa8c87b2d0a5779f5b9.tar.gz
gnu: Add bamutils.
* gnu/packages/bioinformatics.scm (bamutils): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1f018befe6..66e790367d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -326,6 +326,37 @@ instance, it implements several methods to assess contig-wise read coverage.")
BAM files.")
(license license:expat)))
+(define-public bamutils
+ (package
+ (name "bamutils")
+ (version "1.0.13")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://genome.sph.umich.edu/w/images/7/70/"
+ "BamUtilLibStatGen." version ".tgz"))
+ (sha256
+ (base32
+ "0asr1kmjbr3cyf4hkg865y8c2s30v87xvws4q6c8pyfi6wfd1h8n"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:make-flags `("USER_WARNINGS=-std=gnu++98"
+ ,(string-append "INSTALLDIR="
+ (assoc-ref %outputs "out") "/bin"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "https://genome.sph.umich.edu/wiki/BamUtil")
+ (synopsis "Programs for working on SAM/BAM files")
+ (description "This package provides several programs that perform
+operations on SAM/BAM files. All of these programs are built into a
+single executable called @code{bam}.")
+ (license license:gpl3+)))
+
(define-public bcftools
(package
(name "bcftools")