summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-16 10:22:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-16 15:22:06 +0200
commit752be79bf3b0f8de886304f8280e68b9584cafa7 (patch)
treeaeea74ba76e072d0be1b37c7f4fd6493df4e867d /gnu/packages/bioinformatics.scm
parent0598b5d14370fc9e015a3c45effb07758179aa3f (diff)
downloadguix-patches-752be79bf3b0f8de886304f8280e68b9584cafa7.tar
guix-patches-752be79bf3b0f8de886304f8280e68b9584cafa7.tar.gz
gnu: htseq: Update to 2.0.2.
* gnu/packages/bioinformatics.scm (htseq): Update to 2.0.2. [source]: Fetch from git repository. [arguments]: Delete 'build phase; run tests with pytest in 'check phase. [propagated-inputs]: Add python-matplotlib and python-pysam. [inputs]: Remove python-matplotlib and python-pysam. [native-inputs]: Add python-pandas, python-pytest, python-scipy, and swig. [synopsis]: Update. [description]: Update.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm46
1 files changed, 32 insertions, 14 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 38b9fe6cf6..9c18737ade 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3985,26 +3985,44 @@ HMMs).")
(define-public htseq
(package
(name "htseq")
- (version "0.12.3")
+ (version "2.0.2")
+ ;; Sources on pypi do not include everything needed to run the tests.
(source (origin
- (method url-fetch)
- (uri (pypi-uri "HTSeq" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/htseq/htseq")
+ (commit (string-append "release_" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0pk41vkzxsbb5nv644325mh8akmz4zdply9r2s80dgg5b21pgp0b"))))
+ "1kbr4ydjjhizz6r5m3xd4f0wj7qnn8zs0vnzghhgaa0yhbya5r19"))))
(build-system python-build-system)
- (native-inputs
- (list python-cython))
- ;; Numpy needs to be propagated when htseq is used as a Python library.
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ ;; Avoid rebuilding the extension. Everything is built during the
+ ;; 'install phase anyway.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-v")))))))
(propagated-inputs
- (list python-numpy))
- (inputs
- (list python-pysam python-matplotlib))
- (home-page "https://htseq.readthedocs.io/")
- (synopsis "Analysing high-throughput sequencing data with Python")
+ (list python-matplotlib
+ python-numpy
+ python-pysam))
+ (native-inputs
+ (list python-cython
+ python-pandas
+ python-pytest
+ python-scipy
+ swig))
+ (home-page "https://github.com/htseq")
+ (synopsis "Framework for analyzing high-throughput sequencing data")
(description
- "HTSeq is a Python package that provides infrastructure to process data
-from high-throughput sequencing assays.")
+ "This package provides a framework to process and analyze data from
+high-throughput sequencing (HTS) assays")
(license license:gpl3+)))
(define-public java-htsjdk