summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-22 21:02:19 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:46 -0500
commit74af2dd14808732b0db27034fc9423c38adbbc7f (patch)
tree0c1e27ac89b8806b17872ab8e97f2c04797c654c /gnu/packages/bioinformatics.scm
parent3c9a98bf345c947f0c1bfce347ba26e326ea0869 (diff)
downloadguix-patches-74af2dd14808732b0db27034fc9423c38adbbc7f.tar
guix-patches-74af2dd14808732b0db27034fc9423c38adbbc7f.tar.gz
gnu: htslib: Update to 1.14.
* gnu/packages/bioinformatics.scm (htslib): Update to 1.14. (htslib-1.12): New variable. (htslib-1.10, htslib-1.9, htslib-1.3) (htslib-for-samtools-1.2): Normalize style.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm28
1 files changed, 18 insertions, 10 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 487c43a2da..36167d0ba0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4786,7 +4786,7 @@ performance.")
(define-public htslib
(package
(name "htslib")
- (version "1.12")
+ (version "1.14")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4794,7 +4794,7 @@ performance.")
version "/htslib-" version ".tar.bz2"))
(sha256
(base32
- "1jplnvizgr0fyyvvmkfmnsywrrpqhid3760vw15bllz98qdi9012"))))
+ "0pwk8yhhvb85mi1d2qhwsb4samc3rmbcrq7b1s0jz0glaa7in8pd"))))
(build-system gnu-build-system)
;; Let htslib translate "gs://" and "s3://" to regular https links with
;; "--enable-gcs" and "--enable-s3". For these options to work, we also
@@ -4820,9 +4820,20 @@ data. It also provides the @command{bgzip}, @command{htsfile}, and
;; the rest is released under the Expat license
(license (list license:expat license:bsd-3))))
+(define-public htslib-1.12
+ (package/inherit htslib
+ (version "1.12")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/samtools/htslib/releases/download/"
+ version "/htslib-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1jplnvizgr0fyyvvmkfmnsywrrpqhid3760vw15bllz98qdi9012"))))))
+
(define-public htslib-1.10
- (package (inherit htslib)
- (name "htslib")
+ (package/inherit htslib
(version "1.10")
(source (origin
(method url-fetch)
@@ -4834,8 +4845,7 @@ data. It also provides the @command{bgzip}, @command{htsfile}, and
"0wm9ay7qgypj3mwx9zl1mrpnr36298b1aj5vx69l4k7bzbclvr3s"))))))
(define-public htslib-1.9
- (package (inherit htslib)
- (name "htslib")
+ (package/inherit htslib
(version "1.9")
(source (origin
(method url-fetch)
@@ -4848,8 +4858,7 @@ data. It also provides the @command{bgzip}, @command{htsfile}, and
;; This package should be removed once no packages rely upon it.
(define htslib-1.3
- (package
- (inherit htslib)
+ (package/inherit htslib
(version "1.3.1")
(source (origin
(method url-fetch)
@@ -4861,8 +4870,7 @@ data. It also provides the @command{bgzip}, @command{htsfile}, and
"1rja282fwdc25ql6izkhdyh8ppw8x2fs0w0js78zgkmqjlikmma9"))))))
(define htslib-for-samtools-1.2
- (package
- (inherit htslib)
+ (package/inherit htslib
(version "1.2.1")
(source (origin
(method url-fetch)