summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-02-27 18:18:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-27 18:18:34 +0100
commit643d90bf7475d2939b1fbd437965a5b978c8d3ec (patch)
tree03430c49486b12a45d2662e4ae09dcaceea465ff /gnu/packages/bioinformatics.scm
parente6cc426fbb1687f8a88256154f11dd213dd725cf (diff)
downloadguix-patches-643d90bf7475d2939b1fbd437965a5b978c8d3ec.tar
guix-patches-643d90bf7475d2939b1fbd437965a5b978c8d3ec.tar.gz
gnu: infernal: Update to 1.1.3.
* gnu/packages/bioinformatics.scm (infernal): Update to 1.1.3. [native-inputs]: Add python.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4cce508c09..3df146c40d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6608,17 +6608,18 @@ data in the form of VCF files.")
(define-public infernal
(package
(name "infernal")
- (version "1.1.2")
+ (version "1.1.3")
(source (origin
(method url-fetch)
(uri (string-append "http://eddylab.org/software/infernal/"
"infernal-" version ".tar.gz"))
(sha256
(base32
- "0sr2hiz3qxfwqpz3whxr6n82p3x27336v3f34iqznp10hks2935c"))))
+ "0pm8bm3s6nfa0av4x6m6h27lsg12b3lz3jm0fyh1mc77l2isd61v"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl" ,perl))) ; for tests
+ `(("perl" ,perl)
+ ("python" ,python))) ; for tests
(home-page "http://eddylab.org/infernal/")
(synopsis "Inference of RNA alignments")
(description "Infernal (\"INFERence of RNA ALignment\") is a tool for
@@ -6629,7 +6630,7 @@ profile, but it scores a combination of sequence consensus and RNA secondary
structure consensus, so in many cases, it is more capable of identifying RNA
homologs that conserve their secondary structure more than their primary
sequence.")
- ;; Infernal 1.1.2 requires VMX or SSE capability for parallel instructions.
+ ;; Infernal 1.1.3 requires VMX or SSE capability for parallel instructions.
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:bsd-3)))