summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-20 11:54:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-20 12:00:03 +0100
commit61d7da5a1f5b082b55a55ab80242bdf3c283c653 (patch)
treec44f4ac1ebd901fa4f2f9293ee9755fa4b57cf34 /gnu/packages/bioinformatics.scm
parent2b6af630d61dd5b16424be55088de2b079e9fbaf (diff)
downloadguix-patches-61d7da5a1f5b082b55a55ab80242bdf3c283c653.tar
guix-patches-61d7da5a1f5b082b55a55ab80242bdf3c283c653.tar.gz
gnu: Add r-doubletfinder.
* gnu/packages/bioinformatics.scm (r-doubletfinder): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a6088a60a4..357baa289b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11613,6 +11613,39 @@ known and yet unknown splice junctions. Circular-to-linear ratios of circRNAs
can be calculated, and a number of descriptive plots easily generated.")
(license license:artistic2.0)))
+(define-public r-doubletfinder
+ (let ((commit "554097ba4e2c0ed7c28dc7f0b5b75277f3a50551")
+ (revision "1"))
+ (package
+ (name "r-doubletfinder")
+ (version (git-version "2.0.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chris-mcginnis-ucsf/DoubletFinder")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1q1pnqw7ry4syp04wjmvz5bws6z4vg4c340ky07lk0vp577x2773"))))
+ (properties `((upstream-name . "DoubletFinder")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-fields r-kernsmooth r-rocr))
+ (home-page "https://github.com/chris-mcginnis-ucsf/DoubletFinder")
+ (synopsis "Identify doublets in single-cell RNA sequencing data")
+ (description
+ "DoubletFinder identifies doublets by generating artificial doublets
+from existing scRNA-seq data and defining which real cells preferentially
+co-localize with artificial doublets in gene expression space. Other
+DoubletFinder package functions are used for fitting DoubletFinder to
+different scRNA-seq datasets. For example, ideal DoubletFinder performance in
+real-world contexts requires optimal pK selection and homotypic doublet
+proportion estimation. pK selection is achieved using pN-pK parameter sweeps
+and maxima identification in mean-variance-normalized bimodality coefficient
+distributions. Homotypic doublet proportion estimation is achieved by finding
+the sum of squared cell annotation frequencies.")
+ (license license:cc0))))
+
(define-public gffread
;; We cannot use the tagged release because it is not in sync with gclib.
;; See https://github.com/gpertea/gffread/issues/26