summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-03-16 10:27:48 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-16 11:23:27 +0100
commit247d498aaa7938efe9acbd83ea8721e477a7236d (patch)
tree4b367c436979930bb5b1e14a84cdd138351f65e1 /gnu/packages/bioinformatics.scm
parent6a35566df7e2f9876242d10a14074ae662a0037f (diff)
downloadguix-patches-247d498aaa7938efe9acbd83ea8721e477a7236d.tar
guix-patches-247d498aaa7938efe9acbd83ea8721e477a7236d.tar.gz
gnu: Add r-dnacopy.
* gnu/packages/bioinformatics.scm (r-dnacopy): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 190a058cc6..bdd44128fb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3887,6 +3887,28 @@ barplots or heatmaps.")
packages.")
(license license:artistic2.0)))
+(define-public r-dnacopy
+ (package
+ (name "r-dnacopy")
+ (version "1.44.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DNAcopy" version))
+ (sha256
+ (base32
+ "1c1px4rbr36xx929hp59k7ca9k5ab66qmn8k63fk13278ncm6h66"))))
+ (properties
+ `((upstream-name . "DNAcopy")))
+ (build-system r-build-system)
+ (inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "bioconductor.org/packages/DNAcopy")
+ (synopsis "Implementation of a circular binary segmentation algorithm")
+ (description "This package implements the circular binary segmentation (CBS)
+algorithm to segment DNA copy number data and identify genomic regions with
+abnormal copy number.")
+ (license license:gpl2+)))
+
(define-public r-s4vectors
(package
(name "r-s4vectors")