summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorNicolas Vallet <nicolas.vallet@inserm.fr>2021-12-01 09:25:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-01 09:29:26 +0100
commitd7477f09c3e907024297d0640dff3f22a49a59ec (patch)
tree5cbfe6900bdabe7e14a7e942dec2933e29388177 /gnu/packages/bioconductor.scm
parent3411f8d512ae2631e7320010e84b937e5bcf0c34 (diff)
downloadguix-patches-d7477f09c3e907024297d0640dff3f22a49a59ec.tar
guix-patches-d7477f09c3e907024297d0640dff3f22a49a59ec.tar.gz
gnu: Add r-phyloseq.
* gnu/packages/cran.scm (r-phyloseq): New variable Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 9d64388a46..bcd26c7181 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
+;;; Copyright © 2021 Nicolas Vallet <nls.vallet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -15058,3 +15059,41 @@ and other associated metadata. De novo transcriptomes can be linked to the
appropriate sources with linkedTxomes and shared for computational
reproducibility.")
(license license:gpl2)))
+
+(define-public r-phyloseq
+ (package
+ (name "r-phyloseq")
+ (version "1.38.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "phyloseq" version))
+ (sha256
+ (base32 "0k0aj8f7g1vr7l0qcc507b3w67zc1k9x7sdblm7mjb20zqr3916s"))))
+ (properties `((upstream-name . "phyloseq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ade4" ,r-ade4)
+ ("r-ape" ,r-ape)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biomformat" ,r-biomformat)
+ ("r-biostrings" ,r-biostrings)
+ ("r-cluster" ,r-cluster)
+ ("r-data-table" ,r-data-table)
+ ("r-foreach" ,r-foreach)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-igraph" ,r-igraph)
+ ("r-multtest" ,r-multtest)
+ ("r-plyr" ,r-plyr)
+ ("r-reshape2" ,r-reshape2)
+ ("r-scales" ,r-scales)
+ ("r-vegan" ,r-vegan)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/joey711/phyloseq")
+ (synopsis "Handling and analysis of high-throughput microbiome census data")
+ (description
+ "Phyloseq provides a set of classes and tools to facilitate the import,
+storage, analysis, and graphical display of microbiome census data.")
+ (license license:agpl3)))